Announcement

Collapse
No announcement yet.

Attachments in File System Not Displaying

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachments in File System Not Displaying

    Hi,

    I recently moved all my attachments from the MySQL database to a directory outside my WWW root (CHMOD 777). Everything was going fine until I looked at a post with an attachment, which showed a red X instead of the attachment.

    How can I fix this?

    PHP: 4.3.3
    Safe mode: off
    Seriously! - The Definitive Home of All Things Serious
    Seriously! Forums

    To recieve support on these forums, enter your username here.

  • #2
    ...
    Seriously! - The Definitive Home of All Things Serious
    Seriously! Forums

    To recieve support on these forums, enter your username here.

    Comment


    • #3
      What are the permissions of the specific attachment files?
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        I checked that and they're all 777.
        Seriously! - The Definitive Home of All Things Serious
        Seriously! Forums

        To recieve support on these forums, enter your username here.

        Comment


        • #5
          What's the URL to a post with one of these attachments?
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            http://forums.seriouszone.com/showpo...35&postcount=1
            http://forums.seriouszone.com/showpo...76&postcount=1
            Seriously! - The Definitive Home of All Things Serious
            Seriously! Forums

            To recieve support on these forums, enter your username here.

            Comment


            • #7
              I got both those attachments. The first one displayed as an image in the post, and the second one displayed as a text file.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Er....right. I changed vB back to using MySQL for attachments because the file system wasn't working. Give me a minute...
                Seriously! - The Definitive Home of All Things Serious
                Seriously! Forums

                To recieve support on these forums, enter your username here.

                Comment


                • #9
                  Here's what happened:

                  I went through the process, and when I tried to finalize it spun for a few minutes and nothing happened. I checked the database, optimized/repaired the table, and the attachments table still showed the same number of entries and the same 400 MB size. But all the files were on the file system so I manually changed the setting....didn't work.

                  I checked the database this morning and the size (bytes) of the attachment table was next to nothing....

                  I just ran the script again, finalized, and after not long at all it worked. Apparently everything works now, and it seems faster.

                  Thanks
                  Seriously! - The Definitive Home of All Things Serious
                  Seriously! Forums

                  To recieve support on these forums, enter your username here.

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X