Announcement

Collapse
No announcement yet.

Export users database to other forum

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Scott MacVicar
    replied
    just delete the usercache row from the datastore table and re-visit the acp.

    That will fill up the datastore cache again.

    Leave a comment:


  • john_rsd
    replied
    Thanks Scott

    I still have the exported .sql file so perhaps I will also take a backup from the new clean db & try merging the user data on a local db so the forums are still working & I wont have to take nearly a day to rebuild them again while I am pondering or develop my currently inadequate mysql skills.

    The counters within the admincp seemed OK, and I was in/out of the admincp quite a lot as well as clearing my cache & cookies here just in case. It was the forumhome page that did not update but it would accept UN/PW but would not display any posts or users in the meberlist although they were present under the user manager in admincp.
    Prior to the export I had moved all user posts into just one forum to make life a little easier but they just did not appear anywhere after I added them to the new db.

    But at least the site is back up and people can download their firmware updates, they just need to register again and will now probably ask the same support questions again adn i will need to repeat the answers, there was only 79 posts or so anyway, so time to rebuild & answer same support questions again < time to repair db, you know the deal

    Leave a comment:


  • Scott MacVicar
    replied
    the number of registered users is cached.

    Though i'd check you made an entry in the usertextfield and userfield tables since an inner join is done on them when fetching userinfo.

    Check the value of userstats in the datastore table. If it looks out of sync just delete it.

    When you next visit the acp it will re-insert it and call build_user_statistics();

    Leave a comment:


  • john_rsd
    replied
    Pretty dissapointing that no-one wants to step up to the plate on this one as I know for sure it is well within the support teams capabilities to help.

    I have seen people kicking, screaming, sabre rattling and being generally inpolite towards team members and having support members even offer to fix the db for them. I did not expect that much as the error was probably partially down to me. A little help would have been nice, perhaps I was too polite in asking, or everyone is too busy, who knows.

    Anyway, issues are mostly fixed now. I have just dropped the db and created a new one, reinstalled and added the attachments back in.
    Users will just need to put up with the lost posts and having to re-register. Ill post an announcemnt to let them know why.
    The 2.3.2>vb3b7 upgrade problems can now remain one of lifes mysteries.

    Leave a comment:


  • john_rsd
    replied
    Thanks dude

    I gave it a go myself and managed to move the users.

    I can see the entries seem OK now in the db and I can see the users in the admincp. I have ran update/optimise tables/db and updated counters but the forumhome page still shows only 3 users instead of 49.

    I can log on with the imported user name / pw from the other database so the import seems OK at least for authentication.

    My reason for doing this was not to have duplicate users in 2 databases, I did an upgrade on my 2.3.2 site and for many reasons it got hosed and the .sql backup also seems to be screwed. But I could still export the user table from the corrupt db and my hope was to import this data into a fresh install & db to at least save the users the inconvienience of re-registering. I do not care about saving the styles or posts as it is mainly used for file downloads and I have all the files anyway.

    As this is partially a support/db recovery issue a little help would be appreciated please

    Leave a comment:


  • tubedogg
    replied
    It is possible but there is no supported way to do this. For custom scripts you'll need to ask at vbulletin.org.

    Leave a comment:


  • john_rsd
    started a topic Export users database to other forum

    Export users database to other forum

    Is it possible to export the user information only from one forum database to another?

    Are ther any other utility scripts to do this?
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X