Announcement

Collapse
No announcement yet.

Parse Error in config.php line 96

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Parse Error in config.php line 96

    I'm trying to upgrade and I'm getting this error.

    Line 96 is

    \*======================================================================*/

    What could be the problem?
    CredibleHost


  • #2
    Originally posted by bonnmac
    I'm trying to upgrade and I'm getting this error.

    Line 97 is

    \*======================================================================*/

    What could be the problem?
    whats the line above?

    sorry for my bad english I hope, you understand me anyway

    Comment


    • #3
      Make sure that is all on one line and that you uploaded config.php in ASCII.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        Originally posted by fiNal
        whats the line above?
        Thanks!

        This is what's at the bottom. It's the 2nd to last line that says there is an error.

        /*======================================================================*\
        || ####################################################################
        || # Downloaded: 23:03, Tue Aug 12th 2003
        || # CVS: $RCSfile: config.php.new,v $ - $Revision: 1.18 $
        || ####################################################################
        \*======================================================================*/
        ?>
        CredibleHost

        Comment


        • #5
          two possibilities:
          1. you forgot a } anywhere in the code, but in config.php, this would be very unusual
          2. you forgot a quotation mark on the last variable definition (tableprefix)... this would look like that:
          PHP Code:
          $tableprefix 'xyz 
          or probably you didn't upload in ASCII mode

          sorry for my bad english I hope, you understand me anyway

          Comment


          • #6
            Originally posted by fiNal
            two possibilities:
            1. you forgot a } anywhere in the code, but in config.php, this would be very unusual
            2. you forgot a quotation mark on the last variable definition (tableprefix)... this would look like that:
            PHP Code:
            $tableprefix 'xyz 
            Okay. My tables don't have a prefix currently on the 2.3.0 installation. So shouldn't I leave it blank in config.php?

            // Prefix that your vBulletin tables have in the database.
            // For example: $tableprefix = 'vb3_';
            $tableprefix = '';

            Or should I go ahead and put a prefix?
            CredibleHost

            Comment


            • #7
              Originally posted by bonnmac
              Okay. My tables don't have a prefix currently on the 2.3.0 installation. So shouldn't I leave it blank in config.php?

              // Prefix that your vBulletin tables have in the database.
              // For example: $tableprefix = 'vb3_';
              $tableprefix = '';

              Or should I go ahead and put a prefix?
              Well I went ahead and put in a prefix and I now get parse error line 97

              Am I allowed to post my config.php file here? So maybe someone can see what's missing? I don't know anything about programming.
              CredibleHost

              Comment


              • #8
                Originally posted by bonnmac
                Okay. My tables don't have a prefix currently on the 2.3.0 installation. So shouldn't I leave it blank in config.php?

                // Prefix that your vBulletin tables have in the database.
                // For example: $tableprefix = 'vb3_';
                $tableprefix = '';

                Or should I go ahead and put a prefix?
                you have to leave it blank for upgrading, you won't be able to otherwise.
                well, check all the quotation marks and ;s on every var. if all are correct, i dunno what to do... maybe take the config.php.new, rename and configure it again

                sorry for my bad english I hope, you understand me anyway

                Comment


                • #9
                  Originally posted by bonnmac
                  Well I went ahead and put in a prefix and I now get parse error line 97

                  Am I allowed to post my config.php file here? So maybe someone can see what's missing? I don't know anything about programming.
                  do NOT post it here... your mysql-username and password are stored in if you want to, remove these details, rename the file to config.php.txt and send me the link trough pm

                  sorry for my bad english I hope, you understand me anyway

                  Comment


                  • #10
                    Originally posted by bonnmac
                    Well I went ahead and put in a prefix and I now get parse error line 97

                    Am I allowed to post my config.php file here? So maybe someone can see what's missing? I don't know anything about programming.
                    Well I don't know what was wrong but I uploaded config.php.new again and re-editted it and now all is okay.

                    Thank you for trying to help me.
                    CredibleHost

                    Comment


                    • #11
                      Originally posted by bonnmac
                      Well I don't know what was wrong but I uploaded config.php.new again and re-editted it and now all is okay.

                      Thank you for trying to help me.
                      probably you forgott a quotation mark anywhere...

                      sorry for my bad english I hope, you understand me anyway

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X