Announcement

Collapse
No announcement yet.

Fatal error: Allowed memory size of 8388608 bytes exhausted

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Jim, you're fixed up.

    Originally posted by eva2000
    you need root system admin privileges to edit php.ini on the server to increase memory limit to 16M and restart Apache

    you'd need to contact your web host if you don't have access
    Howdee... This is the "web host."
    Jim, I have increased the 8 Mb setting to 16 Mb.
    Let's hope we don't breach it for at least a year


    Polinco

    (This is in the /etc/php.ini file on a Redhat 9.x system using plesk 6.0 for those wanting to know. Type whereis php.ini. After editing with VI editor, save and close, then restart the server with this command: /etc/init.d/httpd/restart)
    Last edited by Polinco; Thu 18 Mar '04, 11:17pm.

    Comment


    • #62
      Our PHP memory limit is already at 32M and we're getting these errors. Should we increase it more? We never had these problems with VB2x

      Our machine is a PIV 2.4G 1.5G memory
      MySQL v3.23.58
      PHP V.4.3.4

      Comment


      • #63
        What's the exact error?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #64
          Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 129 bytes) in /home/explorerforum/www/html/forums/includes/functions_search.php on line 197

          Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 46 bytes) in /home/explorerforum/www/html/forums/includes/functions.php on line 467

          At the time of the error I was starting a new thread with about as much text as is in this post.

          Comment


          • #65
            This means your memory limit is actually at 16M, not 32M. You need to restart Apache after editing php.ini.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #66
              What I want to know is why all of a sudden, do we require 4 times the memory limit as in vb2? And for WORSE performance......

              It's really kind of disturbing that the vb Team just keeps stalling people with this issue and acting like there is no problem. There are LOTS of ppl with this issue and its clearly not going to go away by continuing to up our memory levels....This is not an acceptable resolution in my opinion.....

              I figured with the extremely extended beta period that these problems would be few and far between.....but it seems that the fears that a lot of users had has come true.....WORSE performance, poor UI, and even worse support......

              Got a script to revert to vb2?

              JC

              Comment


              • #67
                If it makes you feel better TheCaver, I was getting errors when the memory was set to 8 mb, so I increased it to 16 mb. Tried doing a search, and error again, so now it's at 32mb. I can definitely say there is a slowdown of our forums after upgrading to VB3, while with VB2, it's blazing.
                - JavaScript Kit | CSS Drive | CodingForums.com | CodeTricks.com

                Comment


                • #68
                  Totally. And my forums are only ~8,000 members and ~500,000 posts. I hate to think whats going to happen as we grow.....

                  All the new features and flexibility means nothing if my users get pissed at how slow the site is and get errors, only to leave....

                  Unacceptable.....

                  JC

                  Comment


                  • #69
                    I believe it could be related to searches on our board... When the limit was at 8Mb with vB2 we never had a problem... We upgraded to vB3 and started getting this error when doing some searches and increased the setting to 16Mb. Now some people still get the error, I believe it's related to posting new threads because of the search for "Similar Threads".

                    When we are hitting the limit, it seems only certain search words are causing the error, could it be that the word is repeated enough times in the search index to fill 16 Mb ? Just speculating, we have a fairly large board with 67K members, 1.3 Million posts, ~1Gb database half of which is the search index.

                    I hope this helps
                    www.speedguide.net | forums.speedguide.net
                    Life would be much easier if I had the source code...

                    Comment


                    • #70
                      I too am a little concerned about this error. I'm just about finished upgrading and I tried doing a search on a single keyword with the forums closed. I received the following error:

                      Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 40 bytes) in /var/www/mysitename.com/html/forums/includes/db_mysql.php on line 281

                      Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 40 bytes) in Unknown on line 0

                      And that's not all - sometimes no error spits out. Sometimes the results just show up as a blank page.

                      And this is with nobody else in the forums but me. I can't wait to see what happens when it's full of people. I've had my server optimized using the suggestions from the optimization forum. I wish I had known about this before I upgraded so I could have waited until this bug was fixed. I'm betting that the large server I just bought will probably be overwhelmed with the increased load that VB3 searches are going to put on it. Please let us know when there's a real fix for the problem. Upping the memory_limit in the php.ini file seems to me like a band-aid that will just cause more performance issues for us. There's got to be a way to optimize the way the search function works to prevent this.
                      Last edited by Ludachris; Sat 24 Apr '04, 8:20am.

                      Comment


                      • #71
                        Seems the errors have subsided on our forums after increasing the buffer from 8MB to 32MB (for the time being)... 4 times the memory for the same functionality compared to vB2. Granted, the forums do appear to be faster with vB3.
                        www.speedguide.net | forums.speedguide.net
                        Life would be much easier if I had the source code...

                        Comment


                        • #72
                          Change memory_limit has not brought successes,if other decisions?

                          Fatal error: Allowed memory size of 50331648 bytes exhausted (tried to allocate 655036 bytes) in /home/www/search.php on line 956

                          Fatal error: Allowed memory size of 50331648 bytes exhausted (tried to allocate 0 bytes) in Unknown on line 0

                          Comment


                          • #73
                            What did you change it to? Whatever it is, it's not high enough and is, in fact, lower than the default setting.
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #74
                              Originally posted by Steve Machol
                              What did you change it to? Whatever it is, it's not high enough and is, in fact, lower than the default setting.
                              Umm... His limit seems to be 48MB
                              www.speedguide.net | forums.speedguide.net
                              Life would be much easier if I had the source code...

                              Comment


                              • #75
                                What version of php are you running?

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X