Announcement

Collapse
No announcement yet.

Fatal error: Allowed memory size of 8388608 bytes exhausted

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • I've had this problem for a while now. I upgraded the server to 2gig ram and dual Pentium 3.4. Allocated 256mb memory in php.ini.
    Still getting it, on a forum with only 80k posts.
    So this is simply ridiculous and it pisses me off that no one cares to resolve this or rewrite the script.

    Comment


    • Please start your own thread with all the relevant details so we can help.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • It's fine when I disable the search feature. So you can help me (and all of us) by writing a search script which is not consuming so much memory.
        I really don't want to switch from your forum to some other solution, but I am basically pushed to it by members of my forum complaining about it.

        Comment


        • resolving vb performance issues..

          Hi jarosciak,

          I think tweaking my.cnf would be worthwhile; my forum has well over 2 million posts with searches enabled. I have php memory limit set to 196MB and it's working smoothly for the most part; I occasionally have problems, but I think it's due to network problems which I am still diagnosing. (problems occur during non-peak hours)

          I run php 4.3.9, apache 2.0.52, mysql 4.1.20, with xcache 1.20 and memcache on CentOS4. vb3.6

          If you happen to get a good, efficient searching script up and running, please let me know.

          Comment


          • Originally posted by blue_asterisk View Post
            I have php memory limit set to 196MB and it's working smoothly for the most part
            That's a bad idea. If one guy comes along and executes the same search that takes 196MB a bunch of times in parallel your server will grind to a halt as it tries to figure out where its going to find that much memory. Unlikely to happen, sure, but its the idea that a web server process could possibly take this much memory that confuses me. Even worse is how vBulletin's engineers think its ok!

            Comment


            • True, searches are a weakpoint for vbulletin and it should be redone for vbulletin 4 (196MB is insane considering that 8MB is default), but I think memcached makes a huge difference. I have 2 Gigs reserved for memcached so mysql doesn't hit the hard drive for most queries. I haven't even used 1MB of swap yet.

              Comment


              • What seach method are you currentlyh using?

                Comment


                • Not full-text searching; I may try enabling it.

                  Comment


                  • Fulltext searching is less stressful over all in compared to the vB search, infact the default vB search is not recomended most of the time anymore either.

                    Comment


                    • Wow, I'm suprised by how little is used for memcache; maybe I should do mysql replication. Cut memcached usage to well less than 16MB. I can't believe how much memory is wasted.

                      Comment


                      • I'd like to see vBulletin use memcached more often. It would be so much faster.

                        Comment


                        • Originally posted by Steve Machol View Post
                          What did you change it to? Whatever it is, it's not high enough and is, in fact, lower than the default setting.
                          Hi Steve,

                          What is the default in php 5x? Irony here is that I Googled for it and this page popped up! LOL

                          Thanks.

                          Comment


                          • Sorry, I don't know what the default is for PHP5.
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • It's probably 8MB, just like it was for 4.x. Remember, the 8MB is supposed to be a mostly unachievable limit set only in place to keep runaway processes from taking down a server.

                              Comment


                              • It is 8Mb, I just upgraded my PHP and got it by it. Took down half of my forum.

                                Changed to 16Mb, but I can't recall what I had it at before.
                                London Fixed-gear and Single-speed

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X