Announcement

Collapse
No announcement yet.

Fresh install but keep posts & memebers

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fresh install but keep posts & memebers

    I'm having huge problems with my beta 4, most seem to be unique to me and they all remain un-resolved!!!

    My latest is I can't post polls (see error at the end of this message) but I also have a major avatar problem & I'm inundated with subscribed thread emails when I'm not subscribed to anything.

    Basically, I want to do a clean install but keep my members and posts. Which tables in the database do I need to back up for that? I'm presuming if I back-up my style, then members, PM, PM text & posts. I just wanted to check there isn't another major table I should be considering keeping?

    Please help as all these errors are driving me and the members nuts!

    cheers

    By the way, my database error for polls (which I hope goes away on a clean install) is

    Database error in vBulletin 3.0.0 Beta 4:
    Invalid SQL:
    INSERT INTO poll (question,dateline,options,votes,active,numberoptions,timeout,multiple,public)
    VALUES ('Can I post a poll','1058808600','Yes|||No|||Don\'t know|||hope so','0|||0|||0|||0',1,4,'0','0','0')
    mysql error: Unknown column 'public' in 'field list'
    mysql error number: 1054

  • #2
    try running the repair.php script in the admin cp first m8 - cos to keep your posts you will need to import them from the existing database

    Comment


    • #3
      tried that

      Originally posted by Pady
      try running the repair.php script in the admin cp first m8 - cos to keep your posts you will need to import them from the existing database
      Thanks for that but already done and no help.

      I realise I have to back up some of the tables but want to do just the bare minimum to keep my members and posts and clean install everything else.

      Comment


      • #4
        Repair.php won't fix this. It appears you do not have the required 'public' column in the poll table.

        What version did you upgrade from and what exactly did you do? Did you run the database conflicts script prior to upgrading?

        http://www.vbulletin.com/forum/showt...threadid=73163
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Hi Steve,

          Yes, I ran the conflicts script first and everything was fine, no problems at all.

          I upgraded 2.3.0 to beta 3 and then to beta 4 with no errors. I then migrated beta 4 from one host to another.

          I think with all the other problems I have the easiest thing for me to do is start again but I don't want to loose my posts or members, hence my origional question.

          Comment


          • #6
            Strange. I have no idea how your poll table ended up missing the 'public' column. Assuming this is the only thing wrong with the databse you can use phpMyAdmin to create a new row in the poll table with these values:

            field: public
            type: tinyint(4)
            attributes:
            Null: No
            Default: 0
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              problems

              Originally posted by Steve Machol
              Assuming this is the only thing wrong ....
              Nope - also unresolved problems are

              http://www.vbulletin.com/forum/showthread.php?t=77893

              http://www.vbulletin.com/forum/showthread.php?t=74021

              Comment


              • #8
                It would appear from this thread and those other that you didn't upgrade correctly.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  fresh install

                  So, getting back to my origional question, I'd like to do a clean install but keep my members and posts. Which tables in the database do I need to back up for that? I'm presuming if I back-up my style, then members, PM, PM text & posts. I just wanted to check there isn't another major table I should be considering keeping?

                  Comment


                  • #10
                    Well, see if you just keep the tables, you're effectively not going to fix anything -- any errors from missing columns will remain because they'll still be missing if you're using the old tables.

                    Are you sure you didn't have any errors during the upgrade?

                    Comment


                    • #11
                      tables

                      Originally posted by canaryforum
                      So, getting back to my origional question, I'd like to do a clean install but keep my members and posts. Which tables in the database do I need to back up for that? I'm presuming if I back-up my style, then members, PM, PM text & posts. I just wanted to check there isn't another major table I should be considering keeping?
                      When I upgraded, no errors and I ran the test script first no probs.

                      The wierd thing is everything was fine (apart from the Avatars, that's always been a problem since I upgraded from 2.3.0) until I migrated. When I migrated I downloaded all the VB files from my server and upped them to the new one. I backed up my database and reinstalled it no problem also.

                      I've got over 500 members and nearly 4,500 posts that I really want to keep. When I initially switched to VB I lost about 2,000 members and 15,000 posts switching from Invision Board (and NOW you release a converter!) I don't want to do that again to the members, they'll kill me.

                      I figure I'll fix the polls and avatars problem at least doing a fresh install and restoring the post and member tables? Who knows, maybe the subscription thing will go away too but I can't make everyone start from scratch again.

                      Comment


                      • #12
                        Well, polls are associated with threads, so I don't know what would happen if you didn't keep that table but kept the threads table.

                        I still think it'd be easier to fix any missing/incorrect columns. Can you do a dump of your database without data (you can do this via phpMyAdmin I know. I don't recall the parameter to do this via mysqldump offhand) and send it to me? I'll compare it to a beta 4 fresh install and let you know how to make the changes.

                        Comment


                        • #13
                          Ed - THANKS VERY MUCH, it's driving me mad! Email sent with the dump.

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X