Announcement

Collapse
No announcement yet.

Move attachments out of database

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Move attachments out of database

    I am attempting to move the attachments out of the database and into a directory, not very succesfully though.

    I get this message,


    We attempted to write a test file to /att, but we were unsuccessful. Please verify that the web server has write/delete permissions for this path.

    What is it relative to?

    I have tried to make the directory in the root of the server, in the admin folder, just about everywhere, and I gave it 777. I would really apreciate "directions for dummies" on this!

    Thanks in advance, any help at all would be great.

    Sebastian
    Sebastián J. Bianchi


  • #2
    When you choose to move attachments to files there is a place to set the path to the dir of your choosing. If you don't create the dir and set the path you'll get that error.
    Also make sure to chmod 711 on attachments dir.
    It is best to be placed above docroot to keep people from leeching files.
    Admins Zone - Resources for Forum Administrators

    Comment


    • #3
      Originally posted by AWS
      When you choose to move attachments to files there is a place to set the path to the dir of your choosing. If you don't create the dir and set the path you'll get that error.
      Also make sure to chmod 711 on attachments dir.
      It is best to be placed above docroot to keep people from leeching files.
      First, thanks for the reply.

      I knew about the dir, and I did create one and set it to 777. I did right on the root of the server, should I do it somewhere else? What would the path be if it were right at the root? I thought it was just the /attachments.
      Sebastián J. Bianchi

      Comment


      • #4
        Are you sure sure there is an /att directory off the root directory on this server? Unless this is a dedicated server and you have root access this is probably a directory in your file space. In that case you need to use the full and exactr path to that directory.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol
          Are you sure sure there is an /att directory off the root directory on this server? Unless this is a dedicated server and you have root access this is probably a directory in your file space. In that case you need to use the full and exactr path to that directory.
          Hello Steve, thanks for bearing with me

          It is indeed a dedicated server, all mine, and well I am sure there is a directory. I can post a screenshot? There the "/" and right off of that I put my directory.
          Sebastián J. Bianchi

          Comment


          • #6
            Sure post a screenshot. Also run 'pwd' to get the full directory path.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Originally posted by Steve Machol
              Sure post a screenshot. Also run 'pwd' to get the full directory path.
              Ok, here is the screen shot of what (I think) is the directory I am attempting to reference.

              Alrighty then, the next picture is error, then the error if I put root/att in the control (different, but still no good and the directory is 777).
              Attached Files
              Last edited by basa; Thu 17 Jul '03, 7:00pm.
              Sebastián J. Bianchi

              Comment


              • #8
                Well the error is clear:

                Error code 13: Permission denied

                Can you PM me shell access to this server and the access to your Admin CP? Please reference this thread when you do.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Originally posted by Steve Machol
                  Well the error is clear:

                  Error code 13: Permission denied

                  Can you PM me shell access to this server and the access to your Admin CP? Please reference this thread when you do.
                  Thanks Steve, PM out to you.
                  Sebastián J. Bianchi

                  Comment


                  • #10
                    You didn't have an '/att' or '/root/att' directory on your server. I created an '/att' one and chmod'd to 777. I think this should work now.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Originally posted by Steve Machol
                      You didn't have an '/att' or '/root/att' directory on your server. I created an '/att' one and chmod'd to 777. I think this should work now.
                      Thanks for the help, but it didn't work. You can try it yourself and you will see that you get the same error - in fact if you could, please do.
                      Sebastián J. Bianchi

                      Comment


                      • #12
                        Something's wrong then. That directory is definitely there and chmod'd to 777. I sent you another PM.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          My latest attempt failed. I don't know what the problem is. The directory does exist, it's chmod'd to 777 and I've used the full and exact path. At this point one of the Devs is going to need to look at this. Sorry.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            Thanks for giving it a shot Steve, I'll turn it in and see what happens.

                            Sebastian
                            Sebastián J. Bianchi

                            Comment


                            • #15
                              Is safe_mode on?

                              You also might not be able to use directories under /root.

                              Try another path such as /home/attachments or so.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X