Announcement

Collapse
No announcement yet.

A registration inconsistancy.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • A registration inconsistancy.

    When I register without email confirmation, I am not given a welcome email. When I turn email registration on, and after I clik the confirmation link, then I get a welcome email.

    So, I would say to leave the email confirmation active, but it seems that the confirmation email is only sent to the member after a link has been clicked somewhere on the forum. As if by clicking a link on the forum activates a send mail command of all emails cued up to be sent. Am I right about that? If I am, then this is not a good thing for a new board as it may be a while before a link is click, thus causing the person who registered to wait before the confirmation email is sent.

    So, what I would like is to be able to turn the email confirmation off, and have the welcome email sent after registration.

    Aric
    http://www.makemydinner.net/downloads/mmd_abadge.gif http://www.adimaging.com/downloads/a...adi_abadge.gif

  • #2
    Ditto

    I read your post as though I wrote it. I have exactly the same issue. A new user does not receive ANY mailings, unless someone produces some activity on the board.

    Mine is a new startup, and I have only two users (both me). When I went into the admincp, I saw the new account "waiting for activation". As soon as I started looking through the new account profile, the new email popped up. I repeated this several times. If I didn't access the aco**** from the admincp, I could wait over an hour and no email would be sent.

    Hopefully we'll see an answer here soon.


    Thanks.

    Comment


    • #3
      This is normal. Emails in vB3 are queued and do not get sent until the forums are accessed. You can either access forumdisplay or showthread to trigger the mail queue, or wait until beta 5 which will change how this works.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        When I register without email confirmation, I am not given a welcome email. When I turn email registration on, and after I clik the confirmation link, then I get a welcome email
        Any idea what is causing this? The email log shows no errors, nothing comming in, and nothing going out.
        http://www.makemydinner.net/downloads/mmd_abadge.gif http://www.adimaging.com/downloads/a...adi_abadge.gif

        Comment


        • #5
          I haven't tested this but I assume it's the same mail queue issue.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Thanks Steve

            I appreaciate your quick response in both of my posts.

            Comment


            • #7
              I don't think it is the mail que issue because even after I click on multiple links, no mail ever gets sent to the server.

              Mail logs show nothing coming in or going out and there are no errors recorded.
              http://www.makemydinner.net/downloads/mmd_abadge.gif http://www.adimaging.com/downloads/a...adi_abadge.gif

              Comment


              • #8
                I just tested this out and I did get the welcome email even with email confirmation turned off. I did have to view a thread first before the email was sent.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Beta 4 also sends out emails when you do anything in the admin cp. Beta 5 gives you the option to disable mail queueing.

                  Comment


                  • #10
                    What do you think my next step should be? What file should I look at? What do you think might cause this for me?
                    http://www.makemydinner.net/downloads/mmd_abadge.gif http://www.adimaging.com/downloads/a...adi_abadge.gif

                    Comment


                    • #11
                      I have no idea. As I said it worked fine on my beta 4 test forum, therefore I doubt this is a bug of any kind.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        If I wanted to change the welcome messge, what file would I edit to do that and where should it be located?
                        http://www.makemydinner.net/downloads/mmd_abadge.gif http://www.adimaging.com/downloads/a...adi_abadge.gif

                        Comment


                        • #13
                          I know this one!

                          Ooo.. Ooo, pick me, pick me!! I know this one!

                          admincp>languages & phrases>phrase manager>Phrase type (at the top) select "Email Body Text">go to page 2> select welcomemail>edit

                          Once you're there, click on "copy default text" button, and edit. once you save, that's you're new email text.

                          I just found this last night. Have fun.

                          Comment


                          • #14
                            Originally posted by erkme73
                            Ooo.. Ooo, pick me, pick me!! I know this one!
                            It like being back in school!
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #15
                              Yes. And I am failing.


                              Here is a change that some one had me do which solved a lot of problems.

                              In includes\functions.php line 1108
                              change

                              Code:

                              mail($email['toemail'], $email['subject'], $email['message'], trim($email['header']));


                              to


                              Code:


                              mail($email['toemail'], $email['subject'], $email['message'], trim($email['header']), "-f [email protected]");
                              Does this identify what could be happening to my welcome message in any way?

                              Here is a link to the other conversation that I have been having.

                              http://www.entropy.ch/phpbb2/viewtopic.php?t=209
                              Last edited by aric; Thu 17 Jul '03, 11:17am.
                              http://www.makemydinner.net/downloads/mmd_abadge.gif http://www.adimaging.com/downloads/a...adi_abadge.gif

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X