Announcement

Collapse
No announcement yet.

mysql error: The table 'session' is full

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • mysql error: The table 'session' is full

    The table hit about 64mb and then couldn't hold anymore data, and this is the error:




    Database error in vBulletin 3.0.0 Beta 3:
    Invalid SQL:
    INSERT INTO session
    (sessionhash, userid, host, idhash, lastactivity, styleid, loggedin)
    VALUES
    ('9793eb27e19208a74f4330ef516ef02a', 1, '63.159.56.93', 'cf609141e7bae6eae4f1d6d430fd31a2', 1056057064, 0, 1)

    mysql error: The table 'session' is full
    mysql error number: 1114


    any idea?


  • #2
    how many users online av and max ? how long a session cookie timeout ?

    try using phpmyadmin - how many records and size of your session table ? try and empty the session table
    :: Always Back Up Forum Database + Attachments BEFORE upgrading !
    :: Nginx SPDY SSL - World Flags Demo [video results]
    :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

    Comment


    • #3
      avg 400
      max 1000

      cookie timeout is set to 2000

      records and size of your session table: 38 megs

      Comment


      • #4
        I am having the same problem on my site as well. Every couple of weeks now it keeps filling up the session table and nobody else can login afterwards. I have to go empty the session table and it will start working again for a few weeks. I'm thinking this is a bug. It will show a very small amount of users online, like 7 - 20, where there are usually 200 online. The weird thing is that if you have it set to remember your login, you can still get to the forums, but if you have to login you will not be able to get in. I can't get into the Admin CP when this happens either, it gives me the mysql error. I tried the command that the MySQL website suggest to increase the max size of the session table, but it doesn't work, says it's invalid syntax. Is there a problem where vBulletin is not removing records from here for some reason and it just keeps filling up, or what?

        Thanks for your help.

        Comment


        • #5
          Originally posted by Thunderpuck
          I am having the same problem on my site as well. Every couple of weeks now it keeps filling up the session table and nobody else can login afterwards. I have to go empty the session table and it will start working again for a few weeks. I'm thinking this is a bug. It will show a very small amount of users online, like 7 - 20, where there are usually 200 online. The weird thing is that if you have it set to remember your login, you can still get to the forums, but if you have to login you will not be able to get in. I can't get into the Admin CP when this happens either, it gives me the mysql error. I tried the command that the MySQL website suggest to increase the max size of the session table, but it doesn't work, says it's invalid syntax. Is there a problem where vBulletin is not removing records from here for some reason and it just keeps filling up, or what?

          Thanks for your help.


          I never found the fix - so now every 3 days I go in and via putty and type in:

          /usr/local/apache/bin/apachectl restart <<< restarts HTTPD


          Then i stop mysql and restart it which does the fix:

          /etc/init.d/mysql start
          /etc/init.d/mysql stop

          Comment


          • #6
            I highly recommend you upgrade to beta 7 if you haven't already.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Originally posted by Steve Machol
              I highly recommend you upgrade to beta 7 if you haven't already.
              ill try that tomorrow and let you know-
              thanks
              jeff

              Comment


              • #8
                i'd decrease the cookie timeout.

                its possible that 64mb worth of sessions were created in the 50 minute timeout.
                Scott MacVicar

                My Blog | Twitter

                Comment


                • #9
                  I'm on beta 7. My timeout is only 45 minutes. Isn't there a way to allow that table to grow larger? That seems like an awful lot of data to fill 64 megs, just doesn't seem right.

                  Comment


                  • #10
                    yeah thats probably 60,000~ rows

                    it would only get that big if you removed the $cronimage from the footer.
                    Scott MacVicar

                    My Blog | Twitter

                    Comment


                    • #11
                      hmmm $cronimage is still there. I'm wondering if the mechanism to remove those rows is just not working??? How can I check that?

                      Comment


                      • #12
                        well how many rows do you have in the session table?

                        are your

                        cleanup.php and cleanup2.php files in includes/cron/
                        Scott MacVicar

                        My Blog | Twitter

                        Comment


                        • #13
                          as of right now, there are 17,544 rows. Ok i just checked I don't even have a cron folder in the includes folder... I have no clue how that didn't get uploaded. I went ahead and uploaded that folder to the server. Is there a way I can manually run those scripts?

                          Comment


                          • #14
                            Ok thanks for your help, after I uploaded the cron folder, I haven't had this problem anymore!

                            Comment


                            • #15
                              you can run them from the admin panel under Scheduled Tasks.
                              Scott MacVicar

                              My Blog | Twitter

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X