Announcement

Collapse
No announcement yet.

Did A stupid thing, need help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cary
    replied
    If you're upgrading, make sure you're running install/upgrade.php - If you're installing vB3 on a database which already has vB2 on it, set a prefix for vB3 in your includes/config.php file

    Leave a comment:


  • JasonP
    replied
    well I just installed 2.3.0 in another folder and tried to run the install and get a database error in it too. Here is what it looks like on the source.

    <html>
    <!--
    --><HTML><HEAD>
    <link rel="stylesheet" href="../cp.css">
    <title>vBulletin 2.3.0 Install script</title>
    <script language="JavaScript">
    <!--
    function SymError()
    {
    return true;
    }
    window.onerror = SymError;
    var SymRealWinOpen = window.open;
    function SymWinOpen(url, name, attributes)
    {
    return (new Object());
    }
    window.open = SymWinOpen;
    //-->
    </script>
    <script language="JavaScript">
    <!--
    function areyousure() {
    if (confirm("You are about to clear ALL data from your database,\nincluding non-vBulletin data.\n\nAre you SURE?")) {
    if (confirm("You have chosen to clear your ENTIRE MySQL database.\nvBulletin and Jelsoft Enterprises Ltd. can hold no responsibility\nfor any loss of data incurred as a result of performing this action.\n\nDo you agree to these terms?")) {
    return true;
    } else {
    return false;
    }
    } else {
    return false;
    }
    }
    -->
    </script>
    </HEAD>
    <BODY>
    <table width="100%" bgcolor="#3F3849" cellpadding="2" cellspacing="0" border="0"><tr><td>
    <table width="100%" bgcolor="#524A5A" cellpadding="3" cellspacing="0" border="0"><tr>
    <td><a href="<A href="http://vbulletin.com/forum">http://vbulletin.com/forum" target="_blank"><img src="cp_logo.gif" width="160" height="49" border="0" alt="Click here to visit the vBulletin support forums"></a></td>
    <td width="100%" align="center">
    <p><font size="2" color="#F7DE00"><b>vBulletin 2.3.0 Install Script</b></font></p>
    <p><font size="1" color="#F7DE00"><b>(Note: Please be patient as some parts of this may take some time.)</b></font></p>
    </td></tr></table></td></tr></table>
    <br>
    <p>Creating table access</p>
    <!-- CREATE TABLE access (
    userid int(10) unsigned DEFAULT '0' NOT NULL,
    forumid smallint(5) unsigned DEFAULT '0' NOT NULL,
    accessmask smallint(5) unsigned DEFAULT '0' NOT NULL
    ) -->
    <html><head><title> Database Error</title><style>P,BODY{FONT-FAMILY:tahoma,arial,sans-serif;FONT-SIZE:11px;}</style><body>
    <!-- Database error in vBulletin Installer :
    Invalid SQL: CREATE TABLE access (
    userid int(10) unsigned DEFAULT '0' NOT NULL,
    forumid smallint(5) unsigned DEFAULT '0' NOT NULL,
    accessmask smallint(5) unsigned DEFAULT '0' NOT NULL
    )
    mysql error: Table 'access' already exists
    mysql error number: 1050
    Date: Wednesday 18th of June 2003 10:48:41 PM
    Script: /vbulletin2/admin/install.php?step=4
    Referer:
    -->
    </table></td></tr></table></form>
    <blockquote><p>&nbsp;</p><p><b>There seems to have been a slight problem with the database.</b><br>
    Please try again by pressing the <a href="javascript:window.location=window.location;">refresh</a> button in your browser.</p>An E-Mail has been dispatched to our <a href="<A href='mailto:[email protected]*******.com">Technical'>mailto:[email protected]*******.com">Technical Staff</a>, who you can also contact if the problem persists.</p><p>We apologise for any inconvenience.</p></blockquote></body></head>
    <script language="JavaScript">
    <!--
    window.open = SymRealWinOpen;
    //-->
    </script>
    </html>
    <script language="JavaScript">
    <!--
    window.open = SymRealWinOpen;
    //-->
    </script>

    <script language="JavaScript">
    <!--
    window.open = SymRealWinOpen;
    //-->
    </script>

    Leave a comment:


  • Cary
    replied
    View the source of the page where you get the error, and post the full error message here.

    Leave a comment:


  • JasonP
    replied
    it is saying database error

    oh brother, lol

    anything else? thanks

    Leave a comment:


  • Cary
    replied
    You can't use a vB2 database with vB3 files. Since you restored your vB2 database, try running the upgrade script again.

    Leave a comment:


  • JasonP
    started a topic Did A stupid thing, need help

    Did A stupid thing, need help

    Hi Everyone,

    Well I was running 2.3.0 and I tried uploading the files and doing the upgrade to 3.0.0 beta 3. Well everything was going until about step 5 and it kicked me out of the page and sent me to the admin login, there I could not log in. So I had a backup of the database from the earlier version, I deleted EVERYTHING, did a fresh install of vb3 and tried to upload the vb2 database, guess what? did not work, lol. Tried repairing, etc. nothing doing. Is there ANYTHING I can do? If I lost all this I will be sick. I am not wild about the idea of RE installing 2.3.0 and uploading the database.

    Thanks
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X