Announcement

Collapse
No announcement yet.

Serious Issues with VB 3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Serious Issues with VB 3

    I have a board that has 40,000 members now and we tried VB 3 Beta out and although it is a fantastic script. Since Sunday we have been experiancing a considerable amount of server problems that are apparently caused by VB 3. I emailed my host and he replied with this message.
    I found mysqld processes that were zombied which leads me to
    believe, that you have scripts opening connections to SQL and not
    closing them.
    I only use one thing for PHP and Mysql and that's VB 3. Therefor I am wondering if this indeed could be vb 3 related on the way it was coded. And also what are some suggesitons for drastically improving the speed and reducing server load on VB 3?
    Last edited by TheMayhem; Mon 16 Jun '03, 4:52pm.

  • #2
    I don't think this will affect the speed, but for server load try setting persistant connections off:

    Code:
    // ****** PERSISTENT CONNECTIONS ******
    // This option allows you to turn persistent connections to MySQL on or off.
    // The difference in performance is negligible for all but the largest boards.
    // If you are unsure what this should be, leave it off.
    // 0 = Off; 1 = On
    $usepconnect = 0;
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by Steve Machol
      I don't think this will affect the speed, but for server load try setting persistant connections off:
      Code:
      // ****** PERSISTENT CONNECTIONS ******
      // This option allows you to turn persistent connections to MySQL on or off.
      // The difference in performance is negligible for all but the largest boards.
      // If you are unsure what this should be, leave it off.
      // 0 = Off; 1 = On
      $usepconnect = 0;
      What file do I edit Steve to do that?

      Comment


      • #4
        That was already set to OFF before Steve.

        Comment


        • #5
          It's config.php and if it's already off then I have no other ideas. I don't understand your host's comment about 'zombie' processes. Turning off persistent connections should close these connections.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            See if Scott can take a look at this thread and if he has any suggestions. He's always really good with server/speed type issues.

            Comment


            • #7
              Originally posted by Steve Machol
              It's config.php and if it's already off then I have no other ideas. I don't understand your host's comment about 'zombie' processes. Turning off persistent connections should close these connections.
              Explanation of zombie processes (see processes section):
              http://www.sitepoint.com/article/817/2

              Comment


              • #8
                This is regardless of the fact that

                1) The vB team are awesome coders and are really good about following standard procedures like unserring vars and closing connections

                2) 99% of the scripts out there DON'T do that good a job doing that, if any

                3) PHP/MySQL does a great job cleaning up after itself even if you are lazy. Open as many mysql connections as you like in a PHP script and it still won't zombie the mysqld daemon processes.


                Originally posted by okrogius
                Explanation of zombie processes (see processes section):
                http://www.sitepoint.com/article/817/2

                Comment


                • #9
                  If your server ran vB2 adequately than it will run vB3. Maybe you have turned every option available to you on? Following are some options that can be enabled/disabled to improve performance. Try them out.

                  Try Disabling:
                  Similiar Threads
                  Thread Preview (Length of Thread Preview)
                  Check Thread Rating
                  Check Thread Subscription
                  Highlight Threads in which User Has Posted
                  Show Users Browsing Threads
                  Show Users Browsing Forums
                  Threaded Mode
                  Update Thread Views Immediately
                  Update Attachment Views Immediately

                  Enable:
                  Cached Posts Lifespan

                  Comment


                  • #10
                    Most of those options were already disabled. However I don't believe I have Cached Posts enabled.

                    Comment


                    • #11
                      I did everything suggested and it's improved my forum loading speed slightly. However the admin cp is still really lagging and the forums are no where near as fast as they were on VB 2. Anymore suggestions?

                      Comment


                      • #12
                        If the admincp lags at startup, do you have the quick stats enabled? Turn them off if you do.

                        Comment


                        • #13
                          I have removed the stats from the admin cp.

                          My problem is the admin cp does lag a lot. And on my forums now its loading for only me and all other users are getting a "Server too Busy" error. Yet when I check my server speed on forums or main site its extremely fast. This is becoming a major problem and I need help on how to stop it.
                          Last edited by TheMayhem; Mon 16 Jun '03, 9:37pm.

                          Comment


                          • #14
                            Nothing from me. Freddie and the others are better qualified to understand the server speed issues.
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #15
                              The server is too busy at the moment. Please try again later.
                              That's the error I'm getting. The forums load super fast, my site is loading super fast yet I get that error. It's weird cause the header and everything works and it just shows that inside a table.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X