Announcement

Collapse
No announcement yet.

Valid Extenstions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Call me crazy but I can't find a file named functions.php in the admincp folder.
    The Enforcerman!

    Comment


    • #17
      sorry attachment.php

      Comment


      • #18
        Same thing. Creates the directory, doesnt go through. Here is the error message.
        We attempted to write a test file to attachments, but we were unsucessful. Please verify that the web server has write/delete permissions for this path.
        The Enforcerman!

        Comment


        • #19
          You removed all 5 @ symbols from that function and saved the file?

          Comment


          • #20
            Yes I removed those symbols. I can tell you the problem. It isnt setting the "test" directory to 777. Its 755.
            The Enforcerman!

            Comment


            • #21
              Well 755 is still acceptable but if you are getting the error message than one of the functions failed and the error should be displayed if you removed the @ supressor.

              Are you on win32 or unix?

              Comment


              • #22
                Can I get in via ftp and take a look? Also need an admin account.

                Comment


                • #23
                  Originally posted by freddie
                  Can I get in via ftp and take a look? Also need an admin account.
                  I am using Unix. I will private message you with info. This is setup on my vb3 test site.
                  The Enforcerman!

                  Comment


                  • #24
                    Ok, the long and short of it is .. you can't use attachments as files because you have safe mode on.

                    Based on limitations of how many files can exist in a directory, attachments are stored in sub directories based on the userid of the poster. Safe mode doesn't allow you to modify files in directories that you don't own. Since apache created the sub-directories and nobody owns them, PHP isn't allowed to write into those directories. This may very well work under other servers such as IIS though.

                    The only other option, if you can't get safe_mode disabled, would be for me to throw all of the attachments into one directory, instead of sub-directories. While not a difficult change to make, you will be limited to how many attachments you can store based on the operating system and the unknown effects of having many files in one directory.
                    Last edited by Freddie Bingham; Mon 16 Jun '03, 2:22pm.

                    Comment


                    • #25
                      Ok. So i need to have open_basedir defined OR turn off safe mode? That shouldnt be a problem.
                      The Enforcerman!

                      Comment


                      • #26
                        Actually with more research, you need safe_mode turned off. I will also add an option to dump all attachments into one directory at your own peril that should work when you don't have safe_mode. I'll make the changes to your files when I have time and see.
                        Last edited by Freddie Bingham; Mon 16 Jun '03, 2:24pm.

                        Comment


                        • #27
                          Dont sweat it. I can get safe mode turned off no problem. Admin is my best friend :P Just glad i can get it fixed.
                          The Enforcerman!

                          Comment


                          • #28
                            I had a similar problem and found that the attachments as files worked only when I put my attachments folder beneath my forums folder. I still had to specify the entire server path to the attachments folder but it wouldnt work anywhere even or above my forums directory.

                            Comment


                            • #29
                              On Linux/Unix basedaccounts can be restricted at the user level limiting where you can write files out to if they are using suexec.
                              Translations provided by Google.

                              Wayne Luke
                              The Rabid Badger - a vBulletin Cloud demonstration site.
                              vBulletin 5 API

                              Comment


                              • #30
                                Originally posted by Kyrnel
                                I had a similar problem and found that the attachments as files worked only when I put my attachments folder beneath my forums folder. I still had to specify the entire server path to the attachments folder but it wouldnt work anywhere even or above my forums directory.
                                Kyrnel is your server running in Safe Mode? Does it have a open_basedir specified? Is it win32 or unix? Both of these can be found in the php info which you can pull up at the bottom left hand of your admin cp.

                                Comment

                                Loading...
                                Working...
                                X