Announcement

Collapse
No announcement yet.

Cannot connect to SQL

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot connect to SQL

    History: My forum has been running for ages and is a bit aged too. Sadly I have a special hack which would have to be totally rewritten so I’m stuck where I am now. Over the years there’s been a lot of people poking fingers in the pie and this server is well and goodly messed up. For instance, cpanel doesn’t work at all, so I can’t use any of those tools. It’s command line linux native commands and editing config files only.

    Current Issue: A week or so ago the server barfed, I asked the host for help and they ran a command I specifically told them not to, went from barfed to all http destroyed. Of course after the employee did this he promptly clocked out and went on vacation for 3 days. When he got back he was able to restore the files he trashed – something everyone else said was impossible.
    Took me about an hour of poking around to figure out and fix the problem. All was good, or so I thought, then I ran a repair/optimize and this trashed the forum…because it ran out of disk space and damaged the tables.

    So I cleared off some space, but the tables had been corrupted. When I tried to log into sql and fix it the root password was not known, so I reset the root password for mysql to match the root password.

    Seems this busted the forum but good, now all I get are , can’t even get into the admin panel.
    Link-ID == false, connect failed
    mysql error:

    mysql error number: 0

    Which I think tells me that vBulletin can’t connect to mysql.

    So I poked around a little more and found that the /include/config.php has the $dbusername set to ‘root’ and $dbpassword set to something cryptic, which obviously doesn’t match what I set root’s mysql password to.

    So I edited the config.php and I've set it to the root password we used, this doesn't work. NO joy.
    I've set the root password back to the one listed in the config.php file, that doesn't work.
    Finally I set the root mysql password back to the root password, changed the config.php back to the root password and exited. Still no joy.
    I know I have the right config.php file because when I change the tech email it changes the error email.

    I’m thinking one solution would be to reset the forum user account’s mysql password to something I would know, then change the config.php to have the user be the forum user and that password, but I have no idea how to go about doing that.

    Anyway, I’ve searched for answers all over the place and I’m stumped. Yes, I searched and read numerous threads on the topic, but it's not getting me to the goal line. I am NOT a linux guru, strictly monkey see monkey do and I have no one to rely on. I’ve renewed my license with vB just to get an answer to this question so I’d sure appreciate it if someone could help.

    Thanks in advance.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X