Announcement

Collapse
No announcement yet.

Wierd Database Error - threadid unknown column...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wierd Database Error - threadid unknown column...

    Hi All!

    i keep getting a wierd database error... full message below.

    ive rebuilt the table as suggested in a couple of posts on the forum, all my VB repair/optimise functions go through with no problems.. but i still keep getting the error emails.

    can anyone help?

    thank you in advance!

    Darren.

    - - - - - - - - -

    Database error in vBulletin 3.0.7:

    Invalid SQL: SELECT threadid , COUNT(*) AS views FROM threadviews GROUP BY threadid
    mysql error: Unknown column 'threadid' in 'field list'

    mysql error number: 1054

    Date: Tuesday 15th of May 2007 04:09:16 PM
    Script: http://www.inthesound.com/forum/cron.php?&rand=99704
    Referer: http://www.inthesound.com/
    Username: Unregistered
    IP Address: 193.243.227.1

  • #2
    Could you perform the following query and post the output:

    DESCRIBE threadviews;
    Want to take your board beyond the standard vBulletin features?
    Visit the official Member to Member support site for vBulletin Modifications: www.vbulletin.org

    Comment


    • #3
      Hi!

      thank you for your help!

      here's the info:

      i couldnt run the query in the admin area, i dont have permission apparently!

      i did it in phpmyadmin:

      Field Type Null Key Default Extra
      attachmentid int(10) unsigned MUL 0


      Does that help?

      hope so!

      thank you again...

      Darren.

      Comment


      • #4
        any ideas - anyone??

        d

        Comment


        • #5
          The threadview table should have one field in it... threadid. If you're is named attachmentid, then you should rename it. Make sure you are looking at the threadview table though.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API

          Comment


          • #6
            Hi Wayne!

            thank you for the reply!

            ive renamed the field and it seems to still be working! very wierd that happened as i have never renamed the field.. do you know why the error occured?

            ill monitor it for a few days, and ill post back my results.

            thank you again!

            Darren.

            Comment


            • #7
              I can't think of anything that would have caused this error.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X