Announcement

Collapse
No announcement yet.

HELP! Trouble with a template

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HELP! Trouble with a template

    I have two fairly similarily called templates
    memberinfo_usersevents gets called at member.php by
    PHP Code:
    while($events $DB_site->fetch_array($eventshosted))
    {
    $events['date'] = vbdate($vboptions['dateformat'],$events['dateline_from']);
    eval(
    '$usersevents .= "' fetch_template('memberinfo_usersevents') . '";');

    the contents with this template shows all ok. It also shows as an uncached template as I have not added it at the top section template lists.

    The next case is trouble
    memberinfo_attendevents gets also called at member.php and is practically identical by its layout. I've also checked that the variables ale all correct. The code pulling it reads:
    PHP Code:
    while($eventsatt $DB_site->fetch_array($eventattend))
    {
    $eventsatt['date'] = vbdate($vboptions['dateformat'],$eventsatt['dateline_from']);
    eval(
    '$attendevents .= "' fetch_template('memberinfo_attendevents') . '";');

    This template does not appear as uncached, even thought I have not added it at the cached templates list. Nor does any related content show up! I've checked, re-checked and again checked everything - in the code and in the templates, but have not been able to spot any flaw... Obviously there must be some i've overlooked!

    The sql's I have at the back-end both seem to work ok - at least according to testing with Dreamweavers SQL editor by running the query's when connected to the database with it's test function. Both execute the results flawlessly.

    To me it seems there is something with the template as it doesn't even appear as uncached when installed. What would be the best place to really start diggin and solvin... Now I REALLY need a whisky...

    Evenn tried to add the templates to the globaltemplates list... Unfortunately nothing changed except that the other one which has worked ok (but appeared as uncached) now is cached properly.

    Thanks for any ideas!
    -Mika
    Last edited by MikaK; Wed 30 Aug '06, 6:58pm. Reason: Just a typo
    www.SoundChilds.net
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X