Announcement

Collapse
No announcement yet.

Blank classes in registration time zone menu?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Blank classes in registration time zone menu?

    I can not have blank classes in the registration time zone menu.
    <option value="-5" class="" selected="selected">(GMT -5:00) Eastern Time (US
    Can't find anything in phrases or templates. Is this something I will have to hack? If so a hint as to where to look would be nice.
    John Bilicki III
    Webmaster of JAB Creations

  • #2
    I'm not sure what you mean.
    All the timezone phrases are in a special phrasegroup called something with timezones.
    Best Regards
    Colin Frei

    Please don't contact me per PM.

    Comment


    • #3
      W3C specifies that class attributes can not be empty.

      So...
      class=""
      ...is not allowed.

      However I have searched through...
      1. Templates
      2. Phrases
      3. Some function files
      Haven't found class="" in anything yet though. I need to find it so I can remove it.

      PS - Thanks for the quick reply!
      John Bilicki III
      Webmaster of JAB Creations

      Comment


      • #4
        This is because it uses the default option template.
        You can replace the content of that template with this:
        Code:
        <option value="$optionvalue" <if condition="$optionclass != ''">class="$optionclass" </if>$optionselected>$optiontitle</option>
        and it'll fix it.

        If you like you can even report it as a bug
        Best Regards
        Colin Frei

        Please don't contact me per PM.

        Comment


        • #5
          Rock on Colin! Thanks!
          John Bilicki III
          Webmaster of JAB Creations

          Comment


          • #6
            Originally posted by JAB Creations
            W3C specifies that class attributes can not be empty.
            Hmm ... validates for me?

            Comment


            • #7
              Assumming your time zone select menu has empty classes like mine did then most likely you are using a lower DTD. I am using XHTML 1.1...looks like your site is using 1.0 transitional.
              John Bilicki III
              Webmaster of JAB Creations

              Comment


              • #8
                And we do, which it does validate the vB3 templates are not ment to be used in 1.1

                Comment


                • #9
                  Hehe, I found only one document.write in the templates, not bad.
                  John Bilicki III
                  Webmaster of JAB Creations

                  Comment

                  Loading...
                  Working...
                  X