Announcement

Collapse
No announcement yet.

Specific searchstring in postbit ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Specific searchstring in postbit ?

    On my forums i have, below the members name/avatar (in postbit_legacy) a counter that shows how many "achievements" they have, i would like to turn that into a clickable link doing a search of that user finding all threads he has started in a specific forum (+subforums).

    Like, if the "postcount" at a user was called "threads started", how do i make it so when people click on that "threads started" link would do a search searching for all threads started by that user, but in a certain forum (+subforums) ?
    http://www.entropiaforum.com

  • #2
    See this thread for help: http://www.vbulletin.com/forum/showthread.php?t=107955

    You'd probably want to use:

    search.php?starteronly=1&searchuser=$bbuserinfo[username]&childforums=1&forumchoice[]=X

    Exchange X with the forumid.
    Best Regards
    Colin Frei

    Please don't contact me per PM.

    Comment


    • #3
      That didnt work, when placing that in a phrase it opens the search page with the field "search by user" prefilled with "$bbuser[username]" (as written, not an actual username) instead of doing the actual search of the username.

      When placing it directly in postbit_legacy like this...

      Code:
      <a href="http://www.entropiaforum.com/forums/search.php?starteronly=1&searchuser=$bbuserinfo[username]&childforums=1&forumchoice[]=9">(View)</a>
      ...also tried adding the "process"...

      Code:
      <a href="http://www.entropiaforum.com/forums/search.php?process&starteronly=1&searchuser=$bbuserinfo[username]&childforums=1&forumchoice[]=9">(View)</a>
      ..then it also opens the search page without doing the search, but this time with my own username prefilled in the "search by user" field, instead of the username i want to search for.



      UPDATE:
      I didnt add the do= before the process, so now it is searching, but it searches for my own threads instead of the user i clicked at, $bbuserinfo[username] seems to be myself instead of the user i want to search for.

      UPDATE2:
      and when adding it to a phrase it comes up with an error saying "no user specified".
      Last edited by mindbuster; Tue 14th Mar '06, 3:08pm.
      http://www.entropiaforum.com

      Comment


      • #4
        Sorry, use $post[username] instead of $bbuserinfo[username]
        Best Regards
        Colin Frei

        Please don't contact me per PM.

        Comment


        • #5
          Thanks, working nicely now
          http://www.entropiaforum.com

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X