Announcement

Collapse
No announcement yet.

Link to Custom Avatars Fails

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Link to Custom Avatars Fails

    We've had our forums online for sometime now, but only recently have some members complained of a problem with custom avatars. They don't have a problem with uploading an avatar via their computer, but when entering a URL they recieve the following error:

    The uploaded file is not a valid GIF, JPG, or PNG file. Please ensure that it is and try again.
    I tested this myself with both gifs and jpegs, using different hosts for the file and each time it fails. Yet the same file will upload with no problem when uploading via the computer.

    I done some extensive hunting on the issue on here before making this post and found some advice regarding PHP safe mode. I checked that, and we don't have that enabled, and I also tried the advice given on the off-chance it would work, but it didn't change things.

    I also noticed that some people with the problem were asked to fill out a support ticket and ensure any hacks they have are uninstalled. As we have several installed and actively used hacks on our board, I was hesitant to do this. So I checked the licence information and found I could install another copy of vBulletin on my server providing the directory is password protected so it cannot be publicly accessed. So I done this solely for testing purposes only to try and determine if the problem was caused by an installed hack, and it still exists on an entirely fresh install of vBulletin with no customization done whatsoever.

    So I'm wondering where should I proceed from here? I don't know if I could still get direct support on the test installation I done, or if someone can try to help me out here.

    We also moved servers recently, so it could be something with the current server config, but I wouldn't even know where to start looking. Trying to search the problem on Google is almost impossible as you just get results from users on other forums asking their admins about the issue. Out of interest, I have two licences, so I tried my other forum and it doesn't work on there either, but it's a different error regarding having to get our host to enable something [that one I'm not going to worry about as it's a shared host and smaller forum, not a dedicated server like the one with the problem mentioned above is].

    Abe Babe...

    ~-< C L O V E R F I E L D . . . Best.Movie.Ever! >-~

  • #2
    Try adding this line to your .htaccess file (or create one if it doesn't exist). If your host doesn't allow you to change PHP settings via .htaccess, then you may have to get them to change the option in PHP.INI:

    php_value allow_url_fopen 1
    vBulletin v3.8.0's Implementation of Google Adsense Should Be Avoided At All Costs - Do Your Own Adsense Implementation

    Comment


    • #3
      I have exactly the same problem in 3.0.13. In my php.ini it's already set to:

      allow_url_fopen = On

      any more ideas?
      www.overclockers.com.au

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X