No announcement yet.

Please help - trying to restore db backup

  • Filter
  • Time
  • Show
Clear All
new posts

  • Please help - trying to restore db backup

    I followed the instructions on how to backup database from phpMyAdmin, exported the tables and named the file to save it to my local computer - did this no problem - then i see that my forum is gone - i call my host provider and they tell me this is a vbulletin issue since i was following their directions on how to back up - ridiculous - so I try to restore using the same method, import the sql file, etc but it is saying the db is too big - I am totally screwed but I have the file! so this should be doable, no?

  • #2
    You did not delete your database after making a backup? If not, they are misleading you to who is at fault.


    • #3
      nope absolutely not - just hit the export, named it and selected 'go'


      • #4
        I have not try to download it that way? I used SSH method. You are still with that server?


        • #5
          Not sure what you mean..


          • #6
            Are you still with that host or are you moving to another server?

            Now I know why I never use that method, I hope it works for you when you try to restore your database.


            • #7
              No we are still with this host - we have been (relatively) happy until this event... I am still on hold with their tech support dept - the importing of the file keeps stopping saying "You probably tried to upload too large file. Please refer to documentation for ways to workaround this limit."

              it connects using mysqladmin


              • #8
                How large is your backup?
                phpMyAdmin is good for 1 to 3 mb
                SSH restoring is better for larger backups and you can do this yourself or ask your host for some help.

                Read this to help you in restoring your forum and ask your host if you or if they can do this for you. It is painless to do it yourself after you done it a few time.
                Last edited by Jose Amaral Rego; Mon 6 Feb '06, 11:40am.


                • #9
                  My host says 'for security reasons, they do not allow telnet or SSH access

                  They advised me to break up the .sql file into like 15 smaller .sql files but how on earth is this going to restore my db? I am so frustrated..


                  • #10
                    For security reason? They can track down and ban anyone that causes any trouble. Did they say why they can not do this for you?

                    This is really fishy? I do not know if backing up the way you did could delete files the way they said it did? It could of been done by mistake or they had something to do with deletion of your database and do not want to take the responsiblity of restoring or paying for your time. I am going to read the information on how to backup the way you did and you should give them the link on what information you read to do your backup. I have to see what they say then.
                    Last edited by Jose Amaral Rego; Mon 6 Feb '06, 2:06pm.


                    • #11
                      This is what I have found for your small problem that your host made it such a bigger problem. It can help you to restore your large file back. I hope this does help and your host should of told you on how or what to use to restore your forum.



                      • #12
                        I am so extraordinarily upset with my host at this point - they just basically told me they provide NO support with regard to database management, problems, etc (when I asked how I was supposed to restore via 18 different smaller .sql files)

                        Ok, so if I download mysqldumper (please understand I am not the most advanced when it comes to this stuff) how do I run it? Do I upload it to where my files are hosted? sorry to ask such dumb questions but I am not sure how to do this...

                        thanks so much for your help today..

                        ETA: I have FTP access to my files and I see that there is a .sql file of my db so why can't I utilize this ??? argh
                        Last edited by wendyod10; Mon 6 Feb '06, 3:06pm.


                        • #13
                          Your database is still intact?

                          Who is your host if I may ask?
                          Last edited by Jose Amaral Rego; Mon 6 Feb '06, 3:49pm.


                          • #14
                            Ok here is what I can tell:

                            When I FTP'd into my directory, there is a file called forum_backup02062006.sql which I made today from admincp - that would get me back but I cannot log into the admincp

                            Also, I finished uploading all 16 smaller .sql files and now I am in Mysqladmin and I see the following:


                            Is there a way that I can rebuild the table or db from all the smaller files that I uploaded? does this make sense at all??

                            Hahaa - just read your postscript - RockinSavings.NET and consider me one UNHAPPY customer


                            • #15
                              I am reading this in how to restore?

                              Phone# & email to contact host? They do not have a online help desk? If they are open 24/7 why not? oh well, I am still reading on this.


                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.