Announcement

Collapse
No announcement yet.

Database error in vBulletin 3.0.10

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Database error in vBulletin 3.0.10

    I keep getting the following e-mails:

    Database error in vBulletin 3.0.10:
    Invalid SQL:
    INSERT INTO post
    (threadid, parentid, title, username, userid, dateline, pagetext, allowsmilie,
    showsignature, ipaddress, iconid, visible, attach)
    VALUES
    (163591, , '',
    'stingy', 15115, 1132687080,
    'a subscriber so should be in route to my house', 1, 1,
    '67.183.61.173', 0, 1, 0)

    mysql error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ' '',
    'stingy', 15115, 1132687080,
    'a subscriber so sh
    mysql error number: 1064
    Date: Tuesday 22nd of November 2005 01:18:00 PM
    Script:
    http://www.siccness.net/vb/newreply.php
    Referer: http://www.siccness.net/vb/showthread.php?t=163591

    Thanks in advance
    Gabe Trujillo
    http://siccness.net

  • #2
    SQL Syntax errors are almost always related to modified code. To troubleshoot this, the first thing you need to do is remove any hacks or plugins, then see if you still have this problem.

    If so, reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server.

    Next, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by Steve Machol
      SQL Syntax errors are almost always related to modified code. To troubleshoot this, the first thing you need to do is remove any hacks or plugins, then see if you still have this problem.

      If so, reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server.

      Next, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
      Thanks for your help boss, it seems to be working fine now...

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X