Announcement

Collapse
No announcement yet.

Attachments

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachments

    Hello! I'm trying to fix my attachment problem, and I've noticed that there is no directory set for the attachments.

    /path/to/your/attachment/directory

    I need to change this in order for the attachments to work correctly again, but I don't know what directory this needs to be. I've tried creating one, but get this message:

    We attempted to write a test file to /home/html/sanantonioracing/attachments, but we were unsuccessful. Please verify that the web server has write/delete permissions for this path.

    can anyone give me the original attachment directory so I can plug that in? I have permissions set correctly for that directory - maybe the path is incorrect? any suggestions?

  • #2
    There is no original directory. This is something that you set yourself. Where are your attachments now?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by Steve Machol
      There is no original directory. This is something that you set yourself. Where are your attachments now?
      I honestly don't know where the attachments are. I've got a problem to where we cannot upload attachments (like pictures) to the posts and view them. It says it uploads them but doesn't display anything. I think the reason is because attachment manager shows:

      file_uploads: On open_basedir: None safe_mode: Off upload_tmp_dir: None upload_max_filesize: 10M

      so there's no base dir to save the files in, that's what I believe is causing the images not to load... any thoughts?

      Comment


      • #4
        Go here to see where your attachments are currently stored:

        Admin CP -> Attachments -> Attachment Storage Type
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol
          Go here to see where your attachments are currently stored:

          Admin CP -> Attachments -> Attachment Storage Type
          Attachments are currently being stored in the filesystem at /home/u4/sanantonioracing/html/sanantonioracing/attachments

          I don't see u4 on the server at all... but i do see atachments in html/sanantonioracing/attachments
          it displayed this dir after I turned off Safe mode. Before it sated file system. I think an admin clicked on "Move Items from File System into Database" and caused this whole fiasco... it's rather a pain.

          We didn't have a problem with this before. When I try to rebuild attachment thumbnails I get this error:

          Your version of PHP does not have image support. Please make sure you have enabled GD if your server does support it by going to Options -> vBulletin Options -> Server Settings and Optimization Options

          Diagnostics for upload shows:

          file_uploads: On open_basedir: None safe_mode: Off upload_tmp_dir: None upload_max_filesize: 10M

          here's what the mainpage on Control Panel shows:

          Server Type FreeBSD
          Data Usage 11.68 MB Web Server cgi-fcgi
          Index Usage 2.95 MB
          PHP 4.4.0
          Attachment Usage 32.58 MB
          PHP Max Post Size 8M
          Avatar Usage 0.26 MB
          PHP Memory Limit 32M
          Profile Picture Usage 0.36 MB
          MySQL 4.1.14-log
          MySQL Packet Size 1.00 MB

          Comment


          • #6
            Server claims to have GD2

            Comment


            • #7
              Try this. Add this to config.php to enter into debug mode:

              Under:

              <?php

              Add this line:

              $config['Misc']['debug'] = 1;

              Then to change the attachment directory:

              Admin CP -> vBulletin Options -> Version Info and Other Untouchables -> File Attachment Path

              Remove or comment out the debug line when you are done.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Added that where specified, uploaded the config.php back to perspective folder, but I cannot find where it says Admin CP -> vBulletin Options -> Version Info and Other Untouchables -> File Attachment Path





                vb 3.0.9
                Last edited by BackSideSA; Mon 21st Nov '05, 1:17pm.

                Comment


                • #9
                  Fill out a support ticket at:

                  http://members.vbulletin.com/members...ontactform.php

                  Be sure to include the login info to your Admin CP, phpMyAdmin and FTP. Please also include a complete description of the problem.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Thanks for this. It fixed the problem I was having.

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X