Announcement

Collapse
No announcement yet.

Major DB trouble

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Major DB trouble

    I'm getting major trouble with my db, and everytime I try to access soemthing that is user related (posts, profile, etc) I get something like this:

    Database error in vBulletin 3.0.8:

    Invalid SQL:
    SELECT
    post.*, post.username AS postusername, post.ipaddress AS ip,
    user.*, userfield.*, usertextfield.*,
    icon.title as icontitle, icon.iconpath,
    avatar.avatarpath, NOT ISNULL(customavatar.avatardata) AS hascustomavatar, customavatar.dateline AS avatardateline,
    level,
    NOT ISNULL(deletionlog.primaryid) AS isdeleted, deletionlog.userid AS del_userid, deletionlog.username AS del_username, deletionlog.reason AS del_reason,
    editlog.userid AS edit_userid, editlog.username AS edit_username, editlog.dateline AS edit_dateline,
    editlog.reason AS edit_reason,
    post_parsed.pagetext_html, post_parsed.hasimages,
    IF(displaygroupid=0, user.usergroupid, displaygroupid) AS displaygroupid

    FROM post AS post
    LEFT JOIN user AS user ON(user.userid = post.userid)
    LEFT JOIN userfield AS userfield ON(userfield.userid = user.userid)
    LEFT JOIN usertextfield AS usertextfield ON(usertextfield.userid = user.userid)
    LEFT JOIN icon AS icon ON(icon.iconid = post.iconid)
    LEFT JOIN avatar AS avatar ON(avatar.avatarid = user.avatarid) LEFT JOIN customavatar AS customavatar ON(customavatar.userid = user.userid) LEFT JOIN reputationlevel AS reputationlevel ON(user.reputationlevelid = reputationlevel.reputationlevelid)
    LEFT JOIN deletionlog AS deletionlog ON(deletionlog.primaryid = post.postid AND deletionlog.type = 'post')
    LEFT JOIN editlog AS editlog ON(editlog.postid = post.postid)
    LEFT JOIN post_parsed AS post_parsed ON(post_parsed.postid = post.postid)
    WHERE post.postid IN (0,235399)
    ORDER BY dateline

    mysql error: File './valiantg_forums/customavatar.MYD' not found (Errcode: 2)

    mysql error number: 1105

    Date: Saturday 05th of November 2005 06:21:25 PM
    Script: http://forums.valiantgamers.com/showthread.php?p=235399
    Referer: http://forums.valiantgamers.com/
    Username: Edrick
    IP Address: 201.129.218.220
    I've been trying to solve this for two days and I've got no luck.

    EDIT: Ok, I took a break, and when researching around, i found out that my custom avatar table is messed up, I've tried to repair it though the admin CP, but had no luck, used a query, no luck. any ways I can rebuild my table so it can be found? (I've put the error in bold)
    Last edited by Valiantgamers; Sat 5 Nov '05, 5:42pm.

  • #2
    Ok, I solved this problem, I restored an old table form a really old backup and it worked, thanks a lot for hearing me.

    can anyone close this?

    Comment

    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
    Working...
    X