Announcement

Collapse
No announcement yet.

Avatar Issues (Avatar hyperlink issues)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Avatar Issues (Avatar hyperlink issues)

    The following member reported the following:

    can you change your Avatar?
    I have a Q... are you guys able to change your Avatar? I'm just having problems doing so. I can change it with any of the available avatars, however I cannot upload or 'hyperlink' to any other image as before.

    I miss Alzheimer's face and glasses!!! lol Could someone try that? I just want to make sure it's not my problem before I report this to Admin.

    thanks


    Any pointers please help this is urgent.

    Ali

  • #2
    You need to enable custom avatars in the Usergroup permissions.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I've found it Steve it is set to yes. I have allowed users to upload their profile pics. I'll tests and share with you.

      Ali

      Comment


      • #4
        Hi Steve its still not working. Members can use only the avatars Ive defined but not url based avatars, can you please help this is urgent!

        Comment


        • #5
          To troubleshoot this, the first thing you need to do is remove any hacks, then see if you still have this problem.

          If so, reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server.

          Next, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Steve what about upgrading to version 3. will that solve the problem. I would rather put the effort into that.

            If I go with your approach, how do I know which files are the hacks. All I know is I have not made any changes in the admin control panel and all of a sudden members complained about losing their url avatars? So I know its not a hack.

            www.omdur.com

            Comment


            • #7
              Without knowing what is causing this problem I can't say if upgrading will fix this or not. I can say that you should not have this problem with an unmodified vB and the correct permissions.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                So if I want to remove any hacks how do I know which hacks to remove. Regarding re-uploading the non-image files which files are you talking about. DO you have a step by step guide, since this is a risky step.

                Also how much would it cost to have vbulletin troubleshoot this issue for me?
                This is not a money making website so I don't expect to spend much.
                Ali

                Comment


                • #9
                  Your support is free, that said, we only support boards with no hacks and no modifications.

                  If you have installed a hack or modification, and you want to ensure that its not the hacks fault, backup your current files. Then reuplaod a fresh set of files from the vBulletin zip folder.

                  Comment


                  • #10
                    I can provide my web server information if you provide me with a support email. Would it be possible for a Vbulletin Support Personel to perform these steps.

                    Comment


                    • #11
                      Steve and Vbulletin Support,

                      I looked into the server error log and this is the error that I found when I tried to upload a customized avatar:

                      [Tue Dec 13 20:57:46 2005] [error] [client 70.231.139.76] File does not exist: /home/httpd/vhosts/mugran.com/httpdocs/favicon.ico
                      [Tue Dec 13 20:57:54 2005] [error] [client 70.231.139.76] File does not exist: /home/httpd/vhosts/mugran.com/httpdocs/favicon.ico
                      [Tue Dec 13 20:57:59 2005] [error] [client 70.231.139.76] File does not exist: /home/httpd/vhosts/mugran.com/httpdocs/favicon.ico
                      [client 70.231.139.76] PHP Warning: move_uploaded_file(): open_basedir restriction in effect. File(/web/mytmp/vbupload9087) is not within the allowed path(s): (/home/httpd/vhosts/mugran.com/httpdocs:/tmp) in /home/httpd/vhosts/mugran.com/httpdocs/omdur/board/includes/functions_upload.php on line 60, referer: http://www.mugran.com/omdur/board/pr...?do=editavatar
                      [Tue Dec 13 20:58:09 2005] [error] [client 70.231.139.76] File does not exist: /home/httpd/vhosts/mugran.com/httpdocs/favicon.ico

                      What does this mean? Which files do I need to replace or modify. Please help this is urgent and my traffic depends on this.

                      Ali

                      Comment


                      • #12
                        Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

                        Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          Steve,

                          I enabled it. the url is

                          http://www.vbulletin.com/forum/showthread.php?p=1033515&posted=1#post1033515

                          The url for the admincp is

                          www.mugran.com/omdur/board/admincp

                          I have sent you the login details in a Private Message, plase check your Inbox.

                          Thanks

                          Ali

                          Comment


                          • #14
                            You have open_basedir restrictions on your server. To get uploads to work you need to create a 'tmp' subdirectory under your httpdocs directory and chmod it to 777. Then in the Admin CP set "Upload In Safe Mode?" to 'Yes' and point the "Safe Mode Temp Directory" to that directory. If you placed the tmp directory in the right place, the path to the Safe Mode Temp Directory will be:

                            /home/httpd/vhosts/mugran.com/httpdocs/tmp
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #15
                              Hi Steve,

                              Yes, its working you guys saved my forum. I cant thank you more.

                              Ali

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X