Announcement

Collapse
No announcement yet.

Cannot upload attachments, getting this error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot upload attachments, getting this error

    When a user tries to upload a file it gives you the following error:

    ----------------------------------------------------
    Database error in vBulletin 3.0.9:
    Invalid SQL:
    INSERT INTO attachment
    (userid, dateline, filename, filesize, visible, filehash, posthash, thumbnail_dateline, thumbnail_filesize)
    VALUES
    (5, 1130171760, 'collapse_tcat.gif', 842, 1, '7d4ee4408c6efceb61f49454abbbea92', 'f08bb1fba4fa8f9465bc507baefb5b39', 0, 0)

    mysql error: Duplicate entry '65535' for key 1
    mysql error number: 1062
    Date: Monday 24th of October 2005 11:36:00 AM
    Script: http://www.siccness.net/vb/newattachment.php
    Referer: http://www.siccness.net/vb/newattach...bc507baefb5b39
    Username: B!tCH PLeAsE!
    IP Address: 68.35.132.239
    ----------------------------------------------------

    I've tried to replace the newattachment.php file and did a repair on the table, but no workie.... Maybe I'm doing sumthing wrong...

  • #2
    This indicates you have missed one of the previous upgrade steps which changed the userid field to INT(10). To fix this, go into yourt database with phpMyAdmin and change all userid fields in each table to INT(10).
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Is this where you were talking about? I really dont wanna mess up anything....

      http://siccness.net/sshot.gif

      Comment


      • #4
        That is only one of the fields. You need to check each table for that is suing the userid field and make sure it is INT(10).
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X