Announcement

Collapse
No announcement yet.

"File system directory is not writable" when uploading attachments

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Khashyar
    replied
    By the way, for those of you who might be having avatar upload issues after moving to a new server, the "customavatar" directory also needs to be set to 777.

    Khashyar

    Leave a comment:


  • Khashyar
    replied
    I think that was the answer, Steve.

    I changed ALL of the subdirectory folders within the attachments folder, and I was able to upload a file.

    I also changed the /home/tmp directory to 777 (it was 700).

    I think that the permissions of the subdirectories within the attachments folder were changed to a default 755 when my website files were moved to the new server.

    Khashyar

    Leave a comment:


  • Khashyar
    replied
    Hi Steve,

    I am noticing that within the attachment directory, are other folders with single digit numbers, and even folders withint those directories.

    Do ALL of those directories and subdirectories need to be set to 777? (The subdirectories within the attachment folder are currently set to 755).

    Khashyar

    Leave a comment:


  • Khashyar
    replied
    Hi Steve,

    I could not find a directory path of "/home/vdeck/tmp",

    But I did find "/home/tmp", and I changed the permissions of that folder from 700 to 777, but I am still experiencing the upload error.

    Is there definitely a /home/vdeck/tmp directory on my server that needs to be changed to 777? Or, should changing the permissions on /home/tmp suffice?

    Can I change the setting in VB as to where the temp files are stored on the server?

    Thanks for your help,

    Khashyar

    Leave a comment:


  • Khashyar
    replied
    Thank you, Steve...

    Let me go to the server CP and see if I can do that myself.

    Khashyar

    Leave a comment:


  • Steve Machol
    replied
    For uploads to work on this server, this directory needs to be chmod'd to 777:

    /home/vdeck/tmp

    Leave a comment:


  • Khashyar
    replied
    By the way, are there any other directories, aside from the attachments and the avatar directories, that need to be set to 777 for server stored attachements to be uploaded?

    Leave a comment:


  • Khashyar
    replied
    Ok, Steve.

    I changed the setting for the php public info.

    The URL to the forum is: www.russianmeetingplace.com/russianforum/

    Thanks for your help with the issue.

    Khashyar

    P.S. I thought by posting the issue here instead of submitting a support ticket, that others who might experience the same issue in the future might benefit.

    Leave a comment:


  • Khashyar
    replied
    Thank you, Steve.

    I will get that information for you.

    Khashyar

    Leave a comment:


  • Steve Machol
    replied
    In the Admin CP, click on vBulletin Options and open the Server Settings and Optimization Options section and turn on the Public phpinfo() Display Enabled setting. Then provide the URL to your forums. This may help us troubleshoot this problem.

    Leave a comment:


  • Khashyar
    replied
    Any ideas, anyone?

    I have the files (in this version of VB) being saved on the server, instead of in the MySQL database.

    Khashyar

    Leave a comment:


  • "File system directory is not writable" when uploading attachments

    Hi Everyone,

    In one of my unhacked versions of VB 3.0.7, I changed servers, and when I try to upload a file in a thread, I receive this error:

    "File system directory is not writable"

    I changed the permissions of the "images" and "attachments" folders to 777, but that did not solve the issue.

    Any ideas as to how to solve this issue?

    Thank you,

    Khashyar
    www.russianmeetingplace.com/russianforum/
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X