Announcement

Collapse
No announcement yet.

Backing Up

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Backing Up

    Tried to back up my db using ACP ( I dont NEED to back it up, just going through the process to see what happens) .
    I get this

    Warning: fopen(./forumbackup-09-21-2005-feaa3.sql): failed to open stream: Permission denied in /admincp/backup.php on line 178
    DROP TABLE IF EXISTS access; CREATE TABLE `access` ( `userid` int(10) unsigned NOT NULL default '0', `forumid` smallint(5) unsigned NOT NULL default '0', `accessmask` smallint(5) unsigned NOT NULL default '0', PRIMARY KEY (`userid`,`forumid`) ) TYPE=MyISAM;
    Warning: fwrite(): supplied argument is not a valid stream resource in /admincp/backup.php on line 183

    Then it goes on for a couple of minutes doing its thing and says it has backed up successfully ,except there is no file anywhere.


    Ive also tried using Navicat . The hostname? for the db is localhost but when I try using that in Navicat I get an error message "Cant connect to 'localhost'

  • #2
    OK, sorted out the first problem by CHmodding the admincp directory 777 .

    But does anyone know (and I know this isnt strictly to do with VB itself) how I can sort out the problem of connecting to my db with an external program?
    Surely (probably wrong here) if the host is 'localhost' it looks on your PC??
    For example, I have recently set up a test site on my PC ,and am using EasyPHP . I can connect to that db no problem using 'localhost'

    Comment

    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
    Working...
    X