Announcement

Collapse
No announcement yet.

error with attachments...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • error with attachments...

    when a user tries to upload an attatchment, they get this error..

    Warning: move_uploaded_file(/home/XXX/public_html/forums/images/attachments/f080cff1b9dff72859708128f9228f59): failed to open stream: Permission denied in /includes/functions_file.php on line 274

    Warning: move_uploaded_file(): Unable to move '/tmp/phpC7psCu' to '/home/XXX/public_html/forums/images/attachments/f080cff1b9dff72859708128f9228f59' in /includes/functions_file.php on line 274

    Warning: filesize(): Stat failed for /home/XXX/public_html/forums/images/attachments/f080cff1b9dff72859708128f9228f59 (errno=2 - No such file or directory) in /includes/functions_file.php on line 286

  • #2
    Run the Upload Diagnostics and report back the results:

    Admin CP -> Import & Maintenance -> Diagnostics -> Upload

    Also, in the Admin CP, open the Server Settings and Optimization Options section and turn on the Public phpinfo() Display Enabled setting. Then provide the URL to your forums. This may help us troubleshoot this problem.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Pertinent PHP Settings file_uploads: On open_basedir: None safe_mode: Off upload_tmp_dir: None upload_max_filesize: 16M


      Results No errors occurred while opening the uploaded file for reading.

      http://forums.fordpower.ca

      Comment


      • #4
        You need to chmod your /home/XXX/public_html/forums/images/attachments/ directory to 777, i.e., world-readable and writable.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          thanks that seemed to work. it was working before, dont know why that would have changed all of a sudden.

          D

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X