Announcement

Collapse
No announcement yet.

Upgraded to 3.0.8--now backups from admincp don't work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgraded to 3.0.8--now backups from admincp don't work

    Running mysql dump from the command line works fine, but using backup.php from admincp results in the following error:

    Warning: fopen(./forumbackups/forumbackup-08-12-05-308-2.sql): failed to open stream: Permission denied in \admincp\backup.php on line 177
    I added the path "./forumbackups/" to the path in backup.php.

    Thjis happened once before and I can't remember how I fixed it, but I've checked permissions and nothing is off. As I said, I can use mysqldump to write a backup file into the same directory with no problems.

    Any ideas?

    Thanks!

  • #2
    You need to chmod the admin cp directory to 777 for this to work, or specify the full path to a directoryy that is chmod'd to 777.

    Note: The only reliable method of backing up and restoring a database is with shell access via telnet orssh. Please see the instructions here:

    Backup:
    http://www.vbulletin.com/docs/html/m...nce_ssh_backup

    Restore:
    http://www.vbulletin.com/docs/html/m...ce_ssh_restore

    This is because backing up with a PHP script like that in the Admin CP or phpMyAdmin can result in PHP timeouts errors and an incomplete backup file.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Steve,

      This is a Win2003Svr box...I checked permissions and they seem to be right.

      Bad thing is I had this problem before and was able to fix it.

      Comment


      • #4
        If the forumsbackup directory is world-readable and writable, this will work. Perhaps you should use the full path instead of a relative one.

        Also if you have access to the command line, you should use the more reliable backup option posted above.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Got it fixed...thanks!

          I am using the command line backup exclusively now.

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X