Announcement

Collapse
No announcement yet.

Members can't upload avatars

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Members can't upload avatars

    Whenever a user tries to upload their own avatars, it doesn't work. It just says: "No avatar specified". The limits are set correctly and everything. I found out that the problem is that it tries to set it to my temp directory, which I don't actually have, and can't make one (a whole different story). Anyway, is there any way that I can change the folder that it uploads the images to? Thanks.

    Ty

    Site and forums (Under Construction obviously):
    www.marinersmania.com/
    VISIT MY NEW FORUMS: www.marinersmania.com/forums

  • #2
    By default, avatars are uploaded into the database, they can be moved into a folder on your server. If you have it set to upload to the file system already, it is possible to change the folder to another.

    Both can be done here:

    Admin CP => Avatars => Avatar Storage Type

    Comment


    • #3
      I still can not get it to work. I tried to make this: /images/customavatars, but it doesn't work. Any suggestions? I'm really really bad at this stuff, so it's hard for me to understand. I just got the forums a few weeks ago and I'm still learning.
      VISIT MY NEW FORUMS: www.marinersmania.com/forums

      Comment


      • #4
        Run the Upload Diagnostics and report back the results:

        Admin CP -> Import & Maintenance -> Diagnostics -> Upload
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Yes, I've done this before and I get the same result:

          The attached file's temporary location (C:\WINDOWS\TEMP\phpAC30.tmp) could not be found. The test cannot continue.
          VISIT MY NEW FORUMS: www.marinersmania.com/forums

          Comment


          • #6
            To get uploads to work, you or your host will need create a C:\WINDOWS\TEMP directory and make it world-readable and writable.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Isn't there a way that I can change it somewhere in the script?
              VISIT MY NEW FORUMS: www.marinersmania.com/forums

              Comment


              • #8
                No, this is a server issue.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Ugh. That means I can't at all. my host does not allow me to upload things with \.
                  VISIT MY NEW FORUMS: www.marinersmania.com/forums

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X