Announcement

Collapse
No announcement yet.

Re: Error: Link-ID == false, connect failed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Re: Error: Link-ID == false, connect failed

    Originally posted by Steve Machol
    2) If your forums do work sometimes and the error is intermittent, then the issue is server-related. Some possibilities are:
    a) MySQL isn't accepting new connections. (The server could either be down.
    b) The server reached the MySQL max_connections (server-wide) or max_user_connections (account-based) limit specified in my.in (or my.cnf for Windows.) Note, many servers are being probed for the phpBB worm and other exploits these days and the MySQL server is being overloaded. This could account for these errors.
    c) The server itself could have a high load due to any number of factors not relating to MySQL. This could include massive influx of spam emails (which happened on my forums.) One thing to watch for is the server load at the time of the 'false, connect failed' error.
    a) Server is up and responding to queries. (Uptime 206890)
    b) Not hitting max_connections limit. (max_connections 2000 Max_used_connections 262)
    c) Server is not even close to high load...

    33 processes: 1 running, 32 sleeping
    CPU states: 3.3% user, 0.0% nice, 1.6% system, 1.8% interrupt, 93.4% idle
    Mem: 501M Active, 2790M Inact, 166M Wired, 112M Buf, 432M Free
    Swap: 4096M Total, 4096M Free


    Any other ideas? This is getting quite annoying.

  • #2
    These really are all the known causes of this error:

    http://www.vbulletin.com/forum/showthread.php?t=145058
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Which is why I quoted the part of that thread that applied to my situation. The issue is intermittent and none of your known causes are correct in this case, thus the request for more ideas.

      Comment


      • #4
        I understand, but the fact is that I do not know of any other reasons for this error, nor has anyone else posted heretofore unknown reasons. I will be happy to update that list when I have more info, but for now I can't tell you what I and no one else knows.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Hi All,

          1/ I had the same error coming with the daily backup of datatbase on the server side.
          2/ I had some months ago a disk crash on the server.

          Two more reasons on your list.
          Bernard

          Comment


          • #6
            My site which has been up for years and has had 3.07 up since its release has now started this error nonsense.

            The board has been down since 2:33 this morning. I am receiving loads of emails.

            The error is this:

            Database error in vBulletin :
            Link-ID == false, connect failed
            mysql error:
            mysql error number: 0
            Date: Sunday 07th of August 2005 01:59:54 PM
            Script:
            http://www.donzi.net/forums/showthread.php?t=41059&goto=newpost
            Referer: http://us.f412.mail.yahoo.com/ym/ShowLetter?MsgId=7446_3776611_1209077_1409_864_0_21514_-1_0&Idx=3&YY=27782&inc=25&order=down&sort=date&pos=0&view=a&head=b&box=Inbox
            IP Address: 68.84.83.16

            The ip addresses fluctuate. sometimes Microsloth, then google, and others.
            I even have the robot.txt excluding all the search engines.

            This is getting rediculous. I have read posts in this forum and the answers I hear aren't very reassuring. This is a major problem and It looks like the Vbulletin folks who are posting replies, do not really have an idea whats wrong.

            Mike if you can get us some help diagnosing this widespread problems it would really help.

            Scot VanAlstine [email protected]
            www.donzi.net
            (The late great Donzi Registry Message boards)

            Comment


            • #7
              Its caused when PHP (nothing to do with vBulletin) is unable to make a connection. Its usually caused by a limit on MySQL regarding the number of concurrent connections allowed at any one time, if you have MySQL error logging enabled you'd be able to see what the exact problem is.
              Scott MacVicar

              My Blog | Twitter

              Comment


              • #8
                Hello,
                I have also the same problem in my forum, and the same messeges are sent to me alot :

                Subject: vBulletin (Forum) Database error!

                Database error in vBulletin :

                Link-ID == false, connect failed
                mysql error:

                mysql error number: 0

                Date: Friday 12th of August 2005 03:24:53 PM
                Script: http://www.hajr.org/forum/cron.php?&rand=152852
                Referer: http://www.hajr.org/forum/showthread.php?t=1719
                IP Address: 212.138.64.176
                The mysql server is ok, but the forum is hanging alot these days.

                I hope yuo find the exact reason for this error!

                Thanks

                Comment


                • #9
                  Its not a vBulletin error, its specific a php error trying to connect to MySQL. There is nothing specificly that the vBulletin software can do. Chances are you mysql server is not optimized.

                  Comment


                  • #10
                    Hello,
                    I'll ask the support teem for the server and come back!
                    Thanks.

                    Comment


                    • #11
                      I'm also getting hammered by this error.

                      I've set up in config to email me everytime the database goes down.

                      Guess what every day I'm getting a 1,000+ emails saying connection problem.

                      Raised it with my host and they have no idea what the hell is going on.

                      This is really frustrating.

                      Running on 3.0.8

                      Will ask host to look at the SQL settings but I'm not very confident.

                      Anyone else having problems?????

                      Kind regards,

                      Hanif
                      <Misleading signature removed. Do not do this again!>

                      Comment


                      • #12
                        I'm having the same problem as well running on 3.0.8, I see that message quite often (once an hour at least). I'm also checking with my webhost to see what the settings are for MySql, but i'm not feeling great about it either ... I hope the fix is that simple.

                        Jibly

                        Comment


                        • #13
                          i have the same problem on my VB3.0.7, and in the last 3-4 weeks i get more and more e-mails like this:

                          Subject: vBulletin (Forum) Database error!

                          Database error in vBulletin :

                          Link-ID == false, connect failed
                          mysql error:

                          mysql error number: 0
                          but i dont have more users or traffic on my forum.

                          Comment


                          • #14
                            Hi Everyone,

                            I'm sorry to add my name to this mysql error list as well.... (I must have received 500 of these error emails today)....

                            I contacted my webhost, and they emailed me back and said that they tried to get on my website's forum, and things were working fine. I called them today and told them that receiving over 400 MYSQL error emails in one day was not normal, and that I don't want them to write me another email telling me that everything is o.k....

                            One possible clue....

                            A few days ago, my website was moved from a Linux server, to a FreeBSD server...

                            Does FreeBSD have these kinds of problems?

                            Hopefully we will all discover the solution to this.

                            I will post any info that my webhost gives me.

                            Khashyar
                            www.DalaiLamaFilm.com/community
                            www.russianmeetingplace.com/forums/
                            www.russianmeetingplace.com/russianforum/
                            www.wakan.com/forum

                            Comment


                            • #15
                              Guys best to start you own new thread in server config forum at http://www.vbulletin.com/forum/forum...aysprune=&f=14 and provide info asked at this thread http://www.vbulletin.com/forum/showthread.php?t=70117 to start with
                              :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                              :: Nginx SPDY SSL - World Flags Demo [video results]
                              :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X