Announcement

Collapse
No announcement yet.

3.0.8 includes/functions.php

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 3.0.8 includes/functions.php

    Getting this error after upgrading to 3.0.8 from 3.0.7

    Warning: Invalid argument supplied for foreach() in /includes/functions.php on line 3120

    3.0.8 = foreach ($accesscache["$user[userid]"] AS $forumid => $accessmask)
    3.0.7 = foreach ($accesscache AS $forumid => $accessmask)

    Changing include/functions.php back to the 3.0.7 version got rid of the error.

    Any ideas on why this error is happening?

  • #2
    Ah, the first victim of the upgrade. I hope u made a backup of 3.0.7 and tested your backup.

    Comment


    • #3
      What page was throwing this error? All?

      I think this could happen if the viewing user, which I assume was you, has access masks enabled but doesn't actually have any in the database. Could you send me an ftp login and the vB login of the user with this issue, so that I could look at this further?

      Comment


      • #4
        Originally posted by Freddie Bingham
        What page was throwing this error? All?

        I think this could happen if the viewing user, which I assume was you, has access masks enabled but doesn't actually have any in the database. Could you send me an ftp login and the vB login of the user with this issue, so that I could look at this further?
        Yeah, all of them.

        Yes, I have access masks enabled but mine are currently all set to default so I don't have anything in the access db.

        How to send you the login information? Submit a ticket?

        Comment


        • #5
          You can do it that way or just email me freddie at vbulletin dot com

          Comment


          • #6
            Originally posted by Freddie Bingham
            You can do it that way or just email me freddie at vbulletin dot com
            I submited a ticket, ID: 129942

            Thanks for the quick response.

            Comment


            • #7
              I am getting the same error:

              Warning: Invalid argument supplied for foreach() in /includes/functions.php on line 3120
              I get a blank white page with that displayed upon attempting to login to the Admin CP and it also displays on top of all of the forum pages.

              Good thing I always make a backup. I will be returning to 3.0.7.

              Comment


              • #8
                I also experience the exact same thing with my upgrade, so these's definately something off here.
                Toddler from Hell

                Comment


                • #9
                  My upgrade went about as smooth as expected. Perhaps there is something else causing the problem?

                  Comment


                  • #10
                    Originally posted by Fusion
                    I also experience the exact same thing with my upgrade, so these's definately something off here.
                    Given the multiple reports of this, someone should post this in the 3.0 Bug Traccker.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      I already fixed it but you can fix it another way by simply editing the access masks of the user having the problem. You should find they have "All Default" so just set them "All No" and then back to "All Default".

                      The problem is that the user has "hasaccessmask" set to 1 but they don't actually have any accessmasks set in the database.

                      Comment


                      • #12
                        So does this mean the current 3.0.8 zip file has this fix?
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          Originally posted by Steve Machol
                          So does this mean the current 3.0.8 zip file has this fix?
                          I wouldn't think so.

                          Comment


                          • #14
                            Sorry, I was confused by 'I already fixed it'. Is there a specific fix for the functions.php file?
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #15
                              Or better yet, a fix one can run in eg. phpMyAdmin.. I am unable to access my admin-panel due to this same bug, and have no direct access to the server at the moment. It might be a bit of a stretch to wait 'til after work today.
                              Toddler from Hell

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X