Announcement

Collapse
No announcement yet.

PHPInclude Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PHPInclude Problems

    Hey, im having some problems with PHPInclude, i think im doing it all correctly but seeing as i havent done it for a while i could be missing the plot. Here are the contents of my PHPInclude_Start

    PHP Code:
    ob_start();
    include_once(
    'radioads.php');
    $radio_ads ob_get_contents();
    ob_end_clean(); 
    Ive tryed different variations like ./radioads.php - /home/twomass1/public_html/radioads.php etc... but nothings appearing, also here is the part of my post bit template im using it on:

    PHP Code:
    <if condition="$post[postcount] % 1 == 0">
    <
    br>
    $spacer_open
    <div style="padding:0px 0px $stylevar[cellpadding]px 0px">
    <
    table class="tborder" cellpadding="$stylevar[cellpadding]cellspacing="$stylevar[cellspacing]border="0" width="100%" align="center">
    <
    tr>
    <
    td class="thead" align="left">Random DJ Banner</td>
    </
    tr>
    <
    tr>
    <
    td class="alt1" align="center"><br>$radio_ads<br></td>
    </
    tr>
    </
    table>
    </
    div>
    $spacer_close
    <br>
    </if> 
    But All I Get is the two surrounding <br> tags. If you visit the page seperately it works (http://forum.habboradiouk.com/radioads.php).

    I`d apreciate some input.

    Regards, Paul

  • #2
    The postbit is out of scope. Use this variable in that template:

    Code:
    $GLOBALS[radio_ads]

    Comment


    • #3
      WOW, once again Jake, youve saved my bacon, lol thanks alot

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X