Announcement

Collapse
No announcement yet.

Pertinent PhP settings

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Pertinent PhP settings

    when I ran the diagnostics, I received the follwoing output:


    Pertinent PHP Settings
    file_uploads:Off
    open_basedir:None
    safe_mode:Off
    upload_tmp_dir:None
    upload_max_filesize:


    Where can I change the file_uploads: to on...and should this resolve my users unable to upload avatars issue?

  • #2
    That's a start. You will not be able to have any PHP uploads (attachments or avatars) with file_uploads turned off in php.ini.

    You will need to have root access to this server and change the file_uploads line in php.ini to 'On'. Then you need to restart the web server for the change to take place.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      just curious on this..as the administrator I can upload avatars to the generic avatars folder.

      shouldn't that upload off impact this?

      Comment


      • #4
        How did you upload them? Regardless if you want attachments and avatars uploads to work, you or your host will need to make this change to php.ini.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          I uploaded them through the Admincp/avatars/upload avatar
          menu

          Comment


          • #6
            You will need to turn file_uploads on. Not much more I can add to this.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Just got off the line with web hosting tech.

              I do not have access to the root php.ini file. They will not change the upload to on for security reasons?

              Short of me manually uploading the avatars for each user and placing them in the generic avatar folder, is there any other way of the forum users to upload their own avatars?

              Comment


              • #8
                No sorry. Unless your host changes their mind you will nnot be able to upload attachments or custom avatars at all.

                If they are so concerned about security, they could enable Safe Mode.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X