Announcement

Collapse
No announcement yet.

Error when posting large attachments

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error when posting large attachments

    We are having a problem posting larger attachments. We are trying to post a pdf file that is 2.59M. I allow 6M for that file type and allow total attachmets per post to be 6M. Have the max_allowed_packet in MySQL set to 6M, have the total size for an attachment set to 6M, post_max_size and upload_max_filesize in the php.ini file set to 6M. We are running vBulletin 3.0.7 on a novell server, php 4.2.4 and MySQL 4.0.22A. I have noticed that after I have set the max_allowed_packet to 6M and re-start MySQL is shows up in vB in when I view the MySQL variables, but then the next day its showing as 1M again.

    I dont have any problem with smaller attachments. Only ones over 1 M. So for some reason the setting isnt holding. Here is what I am doing to change the setting:

    mysql> SET GLOBAL max_allowed_packet=6144000;
    mysql> SET SESSION max_allowed_packet=6144000;

    I get a database error when uploading. ANy ideas? Thank you.

  • #2
    What's the error?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Here is the error:

      There seems to have been a slight problem with the IFMC -
      Information Systems Community Forums database.
      Please try again my pressing the refresh button in your browser.

      An E-Mail has been dispatched to our Technical Staff, who you can also
      contact if the problem persists.


      Database error in vBulletin 3.0.7:

      Invalid SQL:

      INSERT INTO attachment
      (userid, dateline, filename
      VALUES
      (16, 120659833, 'Manualpdf',
      '%PDF-1.4\r%


      I am unable to show the rest of the error because it wont let me page over because this causes the browser fo lock up and not respond. THank you.

      Comment


      • #4
        Can you post the last few lines of that error that show the error number and script info?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X