Announcement

Collapse
No announcement yet.

Error: Link-ID == false, connect failed

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error: Link-ID == false, connect failed

    There are two possible sources for this error:

    1) If the error is happening all the time and you cannot access your forums, it is possible your vBulletin configuration is wrong. This could include:
    a) The db info in your config.php file is wrong.
    b) The db user in config.php doesn't have permission to access the database listed in config.php.
    c) The database doesn't exist.

    2) If your forums do work sometimes and the error is intermittent, then the issue is server-related. Some possibilities are:
    a) MySQL isn't accepting new connections. (The server could either be down, rebooting or cannot find the socket.).
    b) The server reached the MySQL max_connections (server-wide) or max_user_connections (account-based) limit specified in my.in (or my.cnf for Windows.) Note, many servers are being probed for the phpBB worm and other exploits these days and the MySQL server is being overloaded. This could account for these errors.
    c) The server itself could have a high load due to any number of factors not relating to MySQL. This could include massive influx of spam emails (which happened on my forums.) One thing to watch for is the server load at the time of the 'false, connect failed' error.

    The server related issues can only be resolved on the server level so you should contact your host if they continue. However there is one vB setting that may help alleviate the issues in 2b but this may not be enough to stop the error completely. That setting is for 'persistent connections' in your config.php file. Edit config.php to turn this off to see if that helps.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.



  • #2
    Here is some futher information regarding this error:
    http://www.vbulletin.com/forum/showt...843#post936843

    Originally posted by Scott MacVicar
    Its caused when PHP (nothing to do with vBulletin) is unable to make a connection. Its usually caused by a limit on MySQL regarding the number of concurrent connections allowed at any one time, if you have MySQL error logging enabled you'd be able to see what the exact problem is.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment

    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
    Working...
    X