Announcement

Collapse
No announcement yet.

Easy way to restore forums?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Steve Machol
    replied
    Yes, different backup methods produce different results. However either one may work. If you want to make sure you are creating the most reliable backup, then use the shell command line process.

    Leave a comment:


  • Rick Grunwald
    replied
    That may be the answer - either example I posted would work?
    My eyes are telling me they are different and that's what I am trying to find out

    Leave a comment:


  • Steve Machol
    replied
    Both methods can be correct. If you want the most reliable method, use the shell one. Not sure what else I can say about this.

    Leave a comment:


  • Rick Grunwald
    replied
    But I have read in here (the forums) that a quick check on the complete-ness is the final lines being variations of:
    INSERT INTO word (wordid, title) VALUES (4338,'ready');
    and this is not the case the gz-ed file looks like th putty file USED to

    Also should an sql file be text or is that binary null when opening in a text editor normal.

    Things have changed and I am not sure which one is correct. I am following your instructions to the letter and it works (no added commands, no extra spaces etc) But the resulting file no longer even has the same ending lines as listed above

    Would anyone be able to tell if I put say the first and last 25 lines of each file in separate files for examination?

    Leave a comment:


  • Steve Machol
    replied
    Yes, the different backup methoods will have some different lines. The only reliable method is from the shell command line.

    Leave a comment:


  • Rick Grunwald
    replied
    What is interesting is the file that was done through putty hads the following:
    -- Dumping data for table `access`
    --

    /*!40000 ALTER TABLE `access` DISABLE KEYS */;
    LOCK TABLES `access` WRITE;
    INSERT INTO `access` VALUES (6,15,1);

    And the one from the gz file:

    -- Dumping data for table `access`
    --
    INSERT INTO access (userid, forumid, accessmask) VALUES (6,15,1);

    What is going on?
    Thanks

    Leave a comment:


  • Rick Grunwald
    replied
    The download following your instructions (using putty) works bur gives me an sql file that ends in something other than it did at one time. THe one crom cpanel gets gz-ed and comes apparantly correctly

    I don't believe the file using putty is ending correctly (corrupt?)
    I have read elsewhere that it should end in one of the "inset into word" yet the one I get via putty ends as shown in the message

    I have used the intructions inPutty in the past and not had that result - the backup was apparantly successful

    THe question is what is going wrong? Am I doing something? I haven't changed anything in putty other than keeping a persistant connection as suggested by the hosts support for an unrelated issue. 2 backups ending two different ways

    Leave a comment:


  • Steve Machol
    replied
    Rick, what is your question? I'm not sure I understand.

    Leave a comment:


  • Rick Grunwald
    replied
    Originally posted by Steve Machol
    I have hit an interesting issue. I have backed up before using putty and your backup commands. I have also used the database backup in CPANEL

    Today I did both. The gz file done ion cpanel ends with
    INSERT INTO word (wordid, title) VALUES (4338,'ready');
    which I understand is an indication of a full backup "insert into word etc.)

    I did one using the format you have in the docs and end up
    1) a message when loading into metapad (notepad replacement) that "The file is not a valid text file It appears to be a binary file. Convert any NULL terminators to spaces and load anyway?" I answer yes just to have a peek. (I've also loaded the file into textpad and no I wouldn't resave it after the convert message - I just wanted to look)

    2)It ends with a last line of:
    /*!40000 ALTER TABLE `word` ENABLE KEYS */;

    The last few lines:
    (4332,'contacted'),(4333,'sherwood'),(4334,'compare'),(4335,'hot-air'),(4336,'balloons'),(4337,'baloon'),(4338,'ready');
    UNLOCK TABLES;
    /*!40000 ALTER TABLE `word` ENABLE KEYS */;

    Now I've unsuccessfully searched for parts of the last lines in each other and they don't seem to exist. I have compared the lines of the beginning of the file(s) and they start off the same. I even changed the ending on the server to "txt" and got it again with the same results (I use cuteftp and checked the logs - yes it downloaded in ASCII mode)

    THe instructions in the docs work - This just started happening and is probably "operator trouble" . Any ideas?
    Last edited by Rick Grunwald; Sat 25 Jun '05, 6:33am.

    Leave a comment:


  • blkatt
    replied
    Originally posted by Seiken2099
    My webhost does not grant me access to SSH/Telnet due to "security issues."
    They advised to go through myphpadmin but when I try to restore I get the following:

    MySQL said:
    #1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'mysql -u ******* -p ******** < /forums/forumbackup.sql' at l
    I had the exact same problem. My situation was a bit more dire than yours. My entire web site was down and I needed to restore my database.

    My webhost does not grant access to SSH/Telnet either. At first I used myPHPadmin and I received the exact same error. There is another way.

    Your backup database (like mine) is probably larger than that allowed by myPHPadmin and as such, the system will time out. For whatever reason, that error message will occur. Your backup database is probably ok.

    Here's what I did: I installed a version of MySQL Server (www.mysql.com).
    Check with your web host on the correct version - this is extremely important. Theoretically, the latest version should work but as I found out, the latest version did not work for me. I had to use a version dated from year 2002! - in order to upload my databse successfully. The restoration procedure is pretty much the same as when using Telnet/SSH per the vBulletin restoration instructions. Your web host should be able to tell you the correct command line and correct mySQL Server version to use for restoration.

    Let me know if you have a problem or question.
    Last edited by blkatt; Sat 25 Jun '05, 8:37am.

    Leave a comment:


  • Steve Machol
    replied
    This means there is a problem with your backup file. Check the line that this error reports.

    Leave a comment:


  • Seiken2099
    replied
    My webhost does not grant me access to SSH/Telnet due to "security issues."
    They advised to go through myphpadmin but when I try to restore I get the following:

    MySQL said:
    #1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'mysql -u ******* -p ******** < /forums/forumbackup.sql' at l

    Leave a comment:


  • Seiken2099
    replied
    Makes sense

    Leave a comment:


  • Steve Machol
    replied
    No. This option can't exist in the Admin CP for the simple reason that you need to already be running the database to access the ACP.

    The only reliable method of backing up and restoring a database is with shell access via telnet or ssh. Please see the instructions here:

    Backup:
    http://www.vbulletin.com/docs/html/m...nce_ssh_backup

    Restore:
    http://www.vbulletin.com/docs/html/m...ce_ssh_restore

    This is because backing up with a PHP script like that in the Admin CP or phpMyAdmin can result in PHP timeouts errors and an incomplete backup file.

    Leave a comment:


  • Seiken2099
    replied
    Thank you sir!

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X