Announcement

Collapse
No announcement yet.

word censor question

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • word censor question

    Hi there. I've place some words in the censorship feature and the replacement variables and I'm having some problems. If I enter the words without curly brackets, the censor works fine. But if I use the brackets, the word isn't picked up. What am I doing wrong?

    For example, if I enter the word
    mate

    then anytime the word shows up it will block those consecutive letters. i.e. shipmate= ship**** , classmates = class****s , mate = ****

    But when I enter {mate}, nothing will get picked up...
    i.e. shipmate = shipmate , classmates = classmates , mate = mate

    Am I missing something? Thanks.

  • #2
    That is exactly how it's supposed to work as per the instructions:

    Type all words you want censored in the field below. Do not use commas to separate words, just use spaces. For example, type "dog cat boy", rather than "dog, cat, boy."

    If you type "dog", all words containing the string "dog" would be censored (dogma, for instance, would appear as "***ma"). To censor more accurately, you can require that censors occur only for exact words. You can do this by placing a censor word in curly braces, as in {dog}. Signifying "dog" in the curly braces would mean that dogma would appear as dogma, but dog would appear as "***". Thus your censor list may appear as: cat {dog} {barn} barn

    Do not use quotation marks and make sure you use curly braces, not parentheses, when specifying exact words.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      hmmmm......any idea why it's not working for me??

      Comment


      • #4
        What exactly is not working the way it's described in the instructions?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          in the example in the instructions, if i used
          dog , this would work fine editing anything with "dog" or "cat" in it such as dog=***, dogma=***ma"

          if i used {dog} , it wouldn't edit anything at all, so dog = dog , dogma = dogma . For some reason, it doesn't recognize it.

          Any ideas?

          Comment


          • #6
            It should work if you've entter the info correctly (and assuming you have not installed any hacks that affect this.) Make sure you have spaces between the words and not hard returns.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              ok, i went through it more thoroughly and see that when it is placed in curly braces in the censorship option, it works ok. but if i use the curly braces in the replacement variable manager, it doesn't recognize it. is that how it should be?

              Comment


              • #8
                Yes. Replacement variables don't use the curly brackets. That's for the censor option only.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Thanks Steve.....very much appreciated.

                  Comment

                  Loading...
                  Working...
                  X