Announcement

Collapse
No announcement yet.

Server Move from Godaddy Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Server Move from Godaddy Problems

    I'm trying to move my board from Godaddy and they do not have Telnet/SSH so I'm forced to do it from PHPmyadmin. When trying to import the datafile to my new server (a small orange) I get the following error.

    #1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'PK' at line 1

    The version I am exporting from is 2.4.0 and the version I am importing to is 2.6.1 so I'm assuming that is causing the issue (not that the error message doesn't blatantly point it ot! )

    To export the file I do the following;

    I select all fields, the Structure & Data option, the Add the Drop Table option, the Complete Inserts option, the Enclose Table and field names in backquotes option and then download the file locally.

    To import the file I just do a simple import through SQL.

    My database size uncompressed is 19 MB, compressed 4.5 so the size should not be an issue. I've tried uploading the the file both compressed and uncompressed just to see but I get the same error.

    I'm not real sure where to go from here or how to correct the issue. Any ideas? Any and all help is appreciated!

    Troy

  • #2
    you can lose the "enclose table names" option. When I was using their hosted option, I did Structure and Data, drop tables, and complete inserts, zipped.

    That's all.

    ALthough - question - are you exporting from phpmyadmin directly to your shell account or are you exporting to your desktop, then uploading to your server?

    Are you maybe uploading the sql file in binary format instead of ascii?

    Comment


    • #3
      I am using the web interface and exporting to my desktop. I just tried using the option you used and am getting the same error. The binary thing makes sense to me though and the garbled text I am getting back tells me it could be the issue.

      How do I go about UL'ing in Binary? The new server does have telnet, should I try the restore using the "preferred method"?

      Thanks,

      Troy

      Comment


      • #4
        Well I'm assuming that you are FTPing the .sql file up to your server. You need to make sure that the FTP program is set to transfer .sql files in ASCII format, NOT in binary.

        What are you using as your ftp tool?

        Comment


        • #5
          I am just using the web interface so Mozilla is the FTP program. I don't see any options in my browser for changing to ASCII and I would assume the web interface for phpmyadmin would be "smart" enough to transfer how it needs?

          Comment


          • #6
            Downloading from phpmyadmin shouldn't be an issue. If you can open the sql file locally and it looks readable (attachments table will look like garbage, but thats on purpose) then its probably ok.

            To force ascii upload you can ftp from the command line. open a command line and type in:
            ftp your.address.here
            enter your username and password to log in
            use the cd command to change the remote dir to where you want the sql file
            enter: ascii to force ascii mode
            use the lcd command to change the local dir to where you stored the sql file
            and then type put myfile.sql to send it to your server.

            WS-FTP, Cute-FTP and several other windows based FTP programs will also allow you to do this more easily but command line will work for a single file transfer.

            Comment


            • #7
              The sql file does look readable. Out of yucks I figured I would try just the structure. I uploaded to the new site using the phpadmin interface and the structured was created fine.

              I then tried doing just the data, same problem.

              I am familiar with FTP'ing and such so no problem there but when using the web interface of phpmyadmin you click the button to browse for the file on your local hd. I don't think there is a way to re-direct it to an ftp location?

              Comment


              • #8
                Ok, I am now trying to do it through SSH and I am getting the same error as the original error. I FTP'd the zip file to the server, did a SSH session, uncompressed the file and the tried to restore the database to get the same error. Quite frustrating I tell ya!

                Troy

                Comment


                • #9
                  Chaeberle,

                  Thanks for your help on this issue. Last night I did a fresh download of the database, up'd it to my ftp in ASCII and then did the SSH method for restoring and all went well. I can only assume that the downloads I previously made were corrupt as well as I know there were a couple of times I did not realize I was transfering using binary format. Live and learn but my site is back up on it's new host.

                  Thanks,

                  Troy

                  Comment


                  • #10
                    Originally posted by Troy McClure
                    Chaeberle,

                    Thanks for your help on this issue. Last night I did a fresh download of the database, up'd it to my ftp in ASCII and then did the SSH method for restoring and all went well. I can only assume that the downloads I previously made were corrupt as well as I know there were a couple of times I did not realize I was transfering using binary format. Live and learn but my site is back up on it's new host.

                    Thanks,

                    Troy
                    Glad it got working.

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X