Announcement

Collapse
No announcement yet.

Upload Error for attachments & avatars

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upload Error for attachments & avatars

    Hi, my forum has been running for 8 months now, after my provider upgraded the php & mysql last week, suddenly user can't upload their own avatar and add attachments.

    Below is the error message:
    Warning: filesize(): open_basedir restriction in effect. File(/tmp/phpIFbtY9) is not within the allowed path(s): (/home/httpd/vhosts/) in /includes/functions_file.php on line 286
    After I read this thread, I checked my PHPinfo and found out that the upload_tmp_dir setting still shows 'no value'. I'm new with PHP, so forgive me for asking what value suppose to be there? How could I solve this problem. What should I ask my provider to do with the settings? Thanks in advance.

    The URL to my phpinfo is http://forum.chip.co.id/index.php?do=phpinfo

    BTW, I also have 2 other forums with exact the same settings & located in the same dedicated server, but the above problem do not occured.
    Last edited by etaslim; Fri 20th May '05, 10:58am.

  • #2
    You have open_basedir restrictions on your server. To get uploads to work you need to create a 'tmp' subdirectory under your httpdocs directory and chmod it to 777. Then in the Admin CP set "Upload In Safe Mode?" to 'Yes' and point the "Safe Mode Temp Directory" to that directory. If you placed the tmp directory in the right place, the path to the Safe Mode Temp Directory will be:

    /home/httpd/vhosts/chip.co.id/httpdocs/tmp
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      thanks for the prompt reply. It works as you've said. But I'm still confused why my other forum don't share the same problem. The setting for Safe Mode Upload Enabled is 'No' and there is no 'tmp' folder under httpdocs directory. However upload attachments & avatars is working fine there. Here's the URL for my other forum ;http://forum.chip.com.my/index.php?do=phpinfo

      Comment


      • #4
        Looking at the phpinfo, you can see that the 'open_basedir' parameter of your second board is including /tmp as an allowed directory. The php configuration of the first board only allows '/home/httpd/vhosts/'.

        Some hosts set their servers up to have a seperate php.ini for each site.
        Want to take your board beyond the standard vBulletin features?
        Visit the official Member to Member support site for vBulletin Modifications: www.vbulletin.org

        Comment


        • #5
          I see. I'll talk to my provider to make the same php configuration for all my forum then. Thanks so much for the help.

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X