Announcement

Collapse
No announcement yet.

Unable to upload files - please assist.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to upload files - please assist.

    Either me or any member that tries cannot upload Avatars, Profile Pictures, or Attachments.

    I recive no errors except when I do the File Upload in Diagnostics. Then I get this error message

    "The attached file's temporary location (C:\WINDOWS\TEMP\phpD174.tmp) could not be found. The test cannot continue."

    file_uploads:Onopen_basedir:Nonesafe_mode:Offupload_tmp_dir:Noneupload_max_filesize:2M

    I contacted my server admin and he said;
    "The directory that you should be using to store temp file is "C:\PHP\uploadtemp", you also need to consider that this server is running PHP 5, so you should contact the software provider and ask them if the forum would work fine in PHP 5."

    Will all the features of my forum work with PHP 5? --- Everything but the attachments seem to work fine.

    Heres the link to my PHP info;
    http://www.usmc0311.com/phpinfo.php?do=phpinfo

    And, I'm running vBulletin v3.0.2

    What file do I access to change the tmp varailbe so that my forum points to "C:\PHP\uploadtemp" rather than "C:\WINDOWS\TEMP\phpD174.tmp"?

    Your help would be greatly appreciate in this matter. Thank you.

    Willie Terrian
    Willie
    More often than not, it's the last thing you try that makes the damn thing work!

  • #2
    To get uploads to work, you need to edit C:\WINDOWS\php.ini and set the upload_tmp_dir setting to a directory on the server that is world-readable and writable.

    Also I believe there are security issues with PHP 5.0.2. You should upgrade to 5.0.4.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      In your php.ini (in your case: C:\WINDOWS\php.ini) change the value of the 'upload_tmp_dir' variable to 'C:\PHP\uploadtemp'.

      That should do the trick.

      I never tried it myself, but vB should be running ok with PHP 5. Not sure however about vB3.0.2, if you run into any problems i suggest you upgrade to the latest version (which would be advisable anyway).
      Want to take your board beyond the standard vBulletin features?
      Visit the official Member to Member support site for vBulletin Modifications: www.vbulletin.org

      Comment


      • #4
        No luck... I'm going crazy.

        My admin added the 'upload_tmp_dir' variable to the php.ini file and set it to 'C:\PHP\uploadtemp'

        I upgraded to 3.0.7

        When I do Diagnostics for uploads, it says the same thing as posted in my first message.

        But now when I try to attach an image to a post I get the following error message.

        Warning: filesize() [function.filesize]: stat failed for C:\WINDOWS\TEMP\phpEC55.tmp in \includes\functions_file.php on line 286

        ...My License was expired, but I renewed it to an owners license before I upgraded about an hour ago.

        The avatars wont show up when I click "Use custom avatar" and upload an image.

        I cannot even enter a link to the avatar and have it show up. It keeps reverting back to "No Avatar Specified" and when I try to upload a profile pic, or link one from my server, it just dont show up. This is awfully frustrating to say the least.

        Do you have any more ideas on this issue? Im perplexed. All these things are set to "allowed" in the admin center, they just dont work!

        I thank you very much for any input you may have on this issue.
        Willie
        More often than not, it's the last thing you try that makes the damn thing work!

        Comment


        • #5
          Sounds liek you now, do not have proper permissions on that directory

          That directory must be allowed access by everybody (its easier this way).

          Comment


          • #6
            Before my last post, the email that was received from My Server Admin contained the following;

            "I've setup the 'upload_tmp_dir' variable as you requested, the directory C:\PHP\uploadtemp already has read/write permissions setup."

            Its not me. I dont have access to the php.ini file that resides on my server. Its a web host provider, I dont do my own hosting. The attachment/profile ic/avatar functions always worked before. (they just stopped working one day)

            Why am I now getting an error message? Before I upgraded I didn't get any error messages.

            Also, How come Diagnostics wants to look to C:\WINDOWS\TEMP\phpEC55.tmp? Is there a place or way for me to change that? It doesn't seem right.

            What am I supposed to do, if it's me? I have no idea. I have tried everything I know of. Its not just me and my computer, its all the users on the forum that have the same problem.
            Attached Files
            Willie
            More often than not, it's the last thing you try that makes the damn thing work!

            Comment


            • #7
              Originally posted by Willie
              My admin added the 'upload_tmp_dir' variable to the php.ini file and set it to 'C:\PHP\uploadtemp'
              No it's not. The upload_tmp_dir setting in your phpinfo still shows 'no value'.

              http://www.usmc0311.com/phpinfo.php?do=phpinfo
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                The proper permissions must be set and Server must be restartred.

                Comment


                • #9
                  Your right. I just mailed my admin and inquired about this problem.

                  Thank you for bringing that to my attention. I would not have thought to look there.

                  I'll post back and let you know if this fixed the problem. Sorry for going off alittle. Im just a bit anxious. I feel like the middle man.
                  Willie
                  More often than not, it's the last thing you try that makes the damn thing work!

                  Comment


                  • #10
                    Yes, the variable was set, but the server needed to be restarted.

                    Thank you very much for all the information guys. I really appreciate it. It was stressin me out.

                    FYI they are running PHP 5.0.4 btw

                    Everything is running top notch.

                    Thanks again for all your help!
                    Willie
                    More often than not, it's the last thing you try that makes the damn thing work!

                    Comment


                    • #11
                      Originally posted by Steve Machol
                      No it's not. The upload_tmp_dir setting in your phpinfo still shows 'no value'.

                      http://www.usmc0311.com/phpinfo.php?do=phpinfo
                      hi all! I have the same problem. My forum has been running for 8 months now, after my provider upgraded the php & mysql last week, suddenly user can't upload their own avatar and add attachments.

                      After I read this thread, I checked my PHPinfo and found out that the upload_tmp_dir setting still shows 'no value'. I'm new with PHP, so forgive me for asking what value suppose to be there? How could I solve this problem. What should I ask my provider to do with the settings? Thanks in advance. BTW, my forum is http://forum.chip.co.id.

                      Comment


                      • #12
                        Etaslim, please start your own thread and incllude all the relevant info..
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          ok, i will

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X