Announcement

Collapse
No announcement yet.

Sessions error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sessions error

    I was trying to reinstall a script that stopped working after I upgraded for some reason, and I went into my phpMyAdmin and deleted all the tables that had referenced that script so I could reinstall it, and now I got this error:

    Code:
    [b]Warning[/b]: Invalid argument supplied for foreach() in [b]/includes/sessions.php[/b] on line [b]271[/b]
       	      
     
     
         	
       	 	 		 	 				 			 			 			 			[indent]Unable to add cookies, header already sent.
    File: /home2/vaelen/public_html/forum/includes/init.php
    Line: 27
    
    [/indent]

  • #2
    Which tables did you delete?

    The first thing I recommend is that you reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I don't have the list of tabnles I deleted, I could probably get them from the arcade script though. I also tried reuploading everything, which did nothing.

      Comment


      • #4
        I think it was the language table that screwd everything up though. In sessions.php:
        Code:
        	// get default language
        	$DB_site->reporterror = 0;
        	$phraseinfo = $DB_site->query_first("
        		SELECT languageid" . fetch_language_fields_sql(0) . "
        		FROM " . TABLE_PREFIX . "language
        		WHERE languageid = " . intval($vboptions['languageid']) . "
        	");
        	foreach($phraseinfo AS $_arrykey => $_arryval)
        	{
        		$bbuserinfo["$_arrykey"] = $_arryval;
        	}
        	$DB_site->reporterror = 1;
        	unset($phraseinfo);

        Comment


        • #5
          It sounds like you may have removed something you shouldn't have. Did you make a backup of the database prior to all of this?

          Try this. Upload the tools.php script in the DO_NOT_UPLOAD folder of the zip file to your Admin CP directory. Then reimport the vbulletin-language.xml file. Immediately remove tools.php when you are done.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Tried that... still nothing T_T;

            How could I do a fresh forum install while keeping my posts/threads/attachments intact?
            Last edited by Vaelen; Sun 15 May '05, 5:51pm.

            Comment


            • #7
              I aksed this before. Did you make a backup of the database prior to all of this?
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                unfortunately I didn't make a back-up, I didn't think it would kill the database that much

                Comment


                • #9
                  Line 27 of init.php:

                  echo "<br /><strong>Warning</strong>: $errstr in <strong>$errfile</strong>$errline</strong><br />";

                  I believe reuploading the original vbulletin-language.xml file should have fixed this. When you did this did it appear to go through okay?
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    It seemed to go through okay - did not return any errors. Still no luck.

                    Comment


                    • #11
                      The only other thing I can think of is to restore the original language and phrase tables via phpMyAdmin (which is what running tools.php should have done.) Fill out a support ticket and ask for Steve:

                      http://members.vbulletin.com/members...ontactform.php

                      Be sure to include the login info to your Admin CP and phpMyAdmin.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        Check your init.php file. It will probably have a space or another character in front of the initial "<?php" or after the ending "?>".

                        Make sure you are using a plain text editor that can handle php-files correct (ie. no dreamweaver etc..).

                        Alternative would be to start by uploading a clean init.php. Same goes for your session.php
                        Want to take your board beyond the standard vBulletin features?
                        Visit the official Member to Member support site for vBulletin Modifications: www.vbulletin.org

                        Comment


                        • #13
                          His phrase, language and style templates were empty. Restoring the default templates fixed this.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X