Announcement

Collapse
No announcement yet.

Minor MySQL error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Minor MySQL error

    Hello Everyone,

    I understand this issue has been posted before but none of the threads could give me the answer I was looking forward. So I thought I would ask.

    This is an error I am only getting on very few occassions.

    Database error in vBulletin :

    Link-ID == false, connect failed
    mysql error:

    mysql error number: 0

    Date: Wednesday 11th of May 2005 09:33:11 PM
    Script: http://www.magazineforall.co.uk/forum/subscription.php?do=addsubscription&f=8
    Referer:
    IP Address: 207.46.98.45

    I understand that this error can be caused by incorrect settings in the config file. I have ensured these are correct.

    Is it possible that the MySQL on my server has got "too many connections" I have looked at other threads which state this could be the problem. I'd like to be sure though before I bother my host about it. I wasn't sure either.

    Thanks in advance

    Matthew
    Best Regards,

    Matthew M (matius4)

  • #2
    The most common reasons for this are:
    - Wrong settings in config.php (in which case you would probably get this always)
    - Wrong permissions for the MySQL database user (same goes as above)
    - Server/MySQL overloaded.
    - In some cases it could be because of a hack installed. Did you install any hacks, if yes which ones?
    Want to take your board beyond the standard vBulletin features?
    Visit the official Member to Member support site for vBulletin Modifications: www.vbulletin.org

    Comment


    • #3
      Thanks for your reply

      I am only getting this error every so often. So is it possible that I can rule these out

      - Wrong settings in config.php (in which case you would probably get this always)
      - Wrong permissions for the MySQL database user (same goes as above)

      I also don't have any hacks installed.

      What should I ask my host to do if the MySQL/sever is getting overloaded?

      Thanks for your time. If anyone else has suggestions I would be very greatful
      Best Regards,

      Matthew M (matius4)

      Comment


      • #4
        you need to get your web host to optimise their my.cnf mysql settings file and increase their max_connections value

        read or point this link to your web hosts http://dev.mysql.com/doc/mysql/en/to...nnections.html
        :: Always Back Up Forum Database + Attachments BEFORE upgrading !
        :: Nginx SPDY SSL - World Flags Demo [video results]
        :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

        Comment


        • #5
          Thanks for your post eva I've got my host onto it. I'll let you know how it goes.
          Best Regards,

          Matthew M (matius4)

          Comment


          • #6
            no probs
            :: Always Back Up Forum Database + Attachments BEFORE upgrading !
            :: Nginx SPDY SSL - World Flags Demo [video results]
            :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X