Announcement

Collapse
No announcement yet.

Directory relocation question

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Directory relocation question

    Ok I changed the path of my forums
    from /forum
    to /forums

    baiscally all I did was rename the directory.

    I'm having a few problems. I'm guessing theres some template edits or core files that still point to /forum

    What is the best way to make sure everything is pointed to the new location?
    Should I reinstall / upgrade in the new location?

  • #2
    Only thing that cares about file paths are the styles

    AdminCP > Styles & Templates > Style Manager > Style Vars (From the drop down) > Image Paths

    Comment


    • #3
      I got that, but I had a problem with the path for attachments as well.
      I went into the DB and changed it but am still getting an error when I try to attach a file..

      Code:
      [b]Warning[/b]: move_uploaded_file(): SAFE MODE Restriction in effect. The script whose uid is 503 is not allowed to access /home owned by uid 0 in [b]/includes/functions_file.php[/b] on line [b]274[/b]
      
      [b]Warning[/b]: filesize(): SAFE MODE Restriction in effect.  The script whose uid is 503 is not allowed to access /home owned by uid 0 in [b]/includes/functions_file.php[/b] on line [b]286[/b]
      Thats what I am getting when I try to upload an attachment

      Comment


      • #4
        You cannot use the option to place attachments in the file system since your server is running with Safe Mode on.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          How can I change that?

          Or what should I tell the host company to do?

          Comment


          • #6
            They need to turn Safe Mode off in PHP.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              I have root access..
              Is there a cmd in SSH I can drop?

              Comment


              • #8
                Edit your server's php.ini file and set safe mode to 'off':

                safe_mode = Off

                You will need to restart Apache after making this change.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  ok I got it turned off.. Now when I try to upload an attachment I get this error..


                  Warning: move_uploaded_file(/home/mxcrazy/mainwebsite_html/forums/attachments/667e3b3f7b28e63347b779207be155f1): failed to open stream: No such file or directory in /includes/functions_file.php on line 274

                  Warning: move_uploaded_file(): Unable to move '/tmp/php10JzRN' to '/home/mxcrazy/mainwebsite_html/forums/attachments/667e3b3f7b28e63347b779207be155f1' in /includes/functions_file.php on line 274

                  Warning: filesize(): Stat failed for /home/mxcrazy/mainwebsite_html/forums/attachments/667e3b3f7b28e63347b779207be155f1 (errno=2 - No such file or directory) in /includes/functions_file.php on line 286
                  Any ideas?

                  Comment


                  • #10
                    What are your attachement storage settings and did you try to move the attachments first?

                    Also in the Admin CP, click on vBulletin Options and open the Server Settings and Optimization Options section and turn on the Public phpinfo() Display Enabled setting. Then provide the URL to your forums.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      CLICK THIS LINK

                      That should be the php info you need.

                      I also enabled it like you said..
                      The URL is www.mxcrazy.com/forums

                      Thanks for your help

                      Comment


                      • #12
                        What are your attachement storage settings and did you try to move the attachments first?
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          Ok I moved the attachments to a database and that seemed to work
                          I cant move them back though.. Even when I did a chmod 777 attachments

                          Should I keep them in the DB? Or what should I do?

                          Comment


                          • #14
                            What are the attachment storage settings you tried to use?
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #15
                              I tired to use what was there..
                              Stored in the file system at (I may get the path wrong)

                              /home/mxcrazy/mainwebsite_html/forums/attachments

                              Even after I changed the permissions to 777 it still cant write to it..
                              Weird.

                              Comment

                              Loading...
                              Working...
                              X