Announcement

Collapse
No announcement yet.

Zip Limitation

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Zip Limitation

    I have changed the limitations to the file upload size in the Admin CP. I want to be able to upload a file at least 3Mb big. But when I increase the numbers for the zip Filesize ammount, and try to upload, i get an error message saying file is to big, or the uploadpage turns into the 'Page cannot be displayed'

    I was told to start a new thread regarding this so here it is.

  • #2
    Besides the attachment settings in vB, your servers setup will prohibit or allow larger uploads.

    You need to take into account phps max upload limit, mysqls max allowed packet, and the scripts max execution time.

    All of these are server wide changes and can only be accomplilished by the host.

    If you are storing files in the filesystemr ather than the database. You only need to worry about php's max upload and the script execution time, granted you are not running in safemode.

    Comment


    • #3
      Server is fine. My brother manages it. It has plenty of space. VB wont allow it to go bigger,

      Comment


      • #4
        Admin CP -> Attachments -> Extensions & Sizes -> zip -> [Edit] -> Max Filesize

        3072000 bytes is 3 megabytes.

        You also need to make sure the upload_max_filesize PHP directive is not limiting you. And for large files that take a long time to upload, you need to make sure the max_execution_time directive is not limiting you... otherwise you will get PHP errors after the time limit passes.

        Comment


        • #5
          In addition to the vB settings, the allowed size of the attachments depends on the PHP and MySQL configuration. You may need to check and change the upload size for both PHP and for MySQL. Note, you'll need to have root access to the server to do this (or have your host do it.) Make these changes to php.ini:

          upload_max_filesize = xM

          ..and my.cnf (or my.ini for Windows systems)

          set-variable=max_allowed_packet=xM

          Change it to the size ('x') you want in Megabytes. Restart the webserver and MySQL after making these changes.

          Also you might want to take a look at this for other settings that affect file uploads:

          http://www.vbulletin.com/forum/showp...0&postcount=12
          http://www.vbulletin.com/forum/showt...319#post748319
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Originally posted by Jake Bunce
            You also need to make sure the upload_max_filesize PHP directive is not limiting you. And for large files that take a long time to upload, you need to make sure the max_execution_time directive is not limiting you... otherwise you will get PHP errors after the time limit passes.
            How do I go about this?

            Comment


            • #7
              You need to edit the php.ini file on your server. Usually your host has to do this.

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X