Announcement

Collapse
No announcement yet.

I just started getting a flood of emails regarding mysql error number: 1064 and I...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • I just started getting a flood of emails regarding mysql error number: 1064 and I...

    I just started getting a flood of emails regarding mysql error number: 1064 and I haven't changed a thing.

    Could someone look at the error below and tell me where or how I may be able to troubleshoot the problem? My board is heavily modified and has been for the past year with no problems, through a server move and all.

    Thanks.


    Code:
    Database error in vBulletin 3.0.1:
    
    Invalid SQL: 
    		SELECT threadid
    		FROM thread AS thread
    		LEFT JOIN deletionlog AS delthread ON(delthread.primaryid = thread.threadid AND delthread.type = 'thread')
    		WHERE forumid IN(8, 16, 49, 13, 53, 54, 55, 56, 71, 60, 57, 25, 66, 65, 42, 63, 11, 48, 34, 17, 59, 35, 43, 44, 45, 50, 51, 74)
    		AND thread.lastpost >= 1115057369
    		AND visible = 1
    		AND delthread.primaryid IS NULL
    		ORDER BY lastpost DESC
    		LIMIT 500t
    	
    mysql error: You have an error in your SQL syntax.  Check the manual that corresponds to your MySQL server version for the right syntax to use near '500t' at line 9
    
    mysql error number: 1064
    
    Date: Monday 02nd of May 2005 04:25:38 PM
    Script: http://www.midsouthraves.org/community/search.php?do=getnew
    Referer: http://www.midsouthraves.org/community/showthread.php?p=789133#post789133
    Username: cullenation
    IP Address: 65.186.254.125

  • #2
    This only happens when I click the 'Get New' posts button, or http://www.midsouthraves.org/communi....php?do=getnew

    i've tried to run Repair / Optimize Tables from the control panel and it didn't resolve anything.

    Comment


    • #3
      Reupload the original search.php file from the vB zip file. Make sure you upload in ASCII and overwrite the one on the server.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        Unzipped the archive, reuploaded search.php, cleared my cache (used a different web browser even) and I'm still getting this exact error

        Comment


        • #5
          Hmmm...don't see how that is possible. The next thing I recommend is that you reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server.

          Next, create a new style and choose no parent style. This will force it to use the default templates. Then change to this style and view your forums with it. Do you have the same problem?
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            I would hope not if I did a clean install.

            I'm going to search for a resolve for this problem since it came out of nowhere. grep isn't finding "500t" anywhere so I'm not sure what i'm going to do. I guess I can start with restoring the backup I made before I moved servers.

            Thanks for the help.

            Comment


            • #7
              Take a look at this setting:

              Admin Control Panel -> vBulletin Options -> Message Searching Options -> Maximum Search Results to Return

              I would guess you will find your 500t there.

              Comment


              • #8
                You beat me to it

                Comment


                • #9
                  Geez, don't you guys have an "isNumeric" and "Val" on that field?

                  Comment


                  • #10
                    Originally posted by Mystics
                    Take a look at this setting:

                    Admin Control Panel -> vBulletin Options -> Message Searching Options -> Maximum Search Results to Return

                    I would guess you will find your 500t there.
                    that was th problem, i ran a search on the database and found it, got home and checked my email and Mystics had called it

                    Thanks for the help guys! It'd have taken forever to remodify my board.

                    I guess when I was showing the control panel to a friend I accidently hit a key.

                    Doh

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X