Announcement

Collapse
No announcement yet.

Ssh Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ssh Problem

    I'm trying to restore my DB and i entered the command and this is what i get:

    bash-2.05a$ mysql -u univer1_main -p bC7Fhh1h univer1_forum < /home/univer1/public_html/back/universal-muscle_com_-_vb
    mysql Ver 12.22 Distrib 4.0.22, for pc-linux (i686)
    Copyright (C) 2002 MySQL AB
    This software comes with ABSOLUTELY NO WARRANTY. This is free software,
    and you are welcome to modify and redistribute it under the GPL license
    Usage: mysql [OPTIONS] [database]
    -?, --help Display this help and exit.
    --auto-rehash Enable automatic rehashing. One doesn't need to use
    'rehash' to get table and field completion, but startup
    and reconnecting may take a longer time. Disable with
    --disable-auto-rehash.
    -A, --no-auto-rehash
    No automatic rehashing. One has to use 'rehash' to get
    table and field completion. This gives a quicker start of
    mysql and disables rehashing on reconnect. WARNING:
    options deprecated; use --disable-auto-rehash instead.
    -B, --batch Print results with a tab as separator, each row on new
    line. Doesn't use history file.
    --character-sets-dir=name
    Directory where character sets are.
    --default-character-set=name
    Set the default character set.
    -C, --compress Use compression in server/client protocol.
    -D, --database=name Database to use.
    -e, --execute=name Execute command and quit. (Output like with --batch).
    -E, --vertical Print the output of a query (rows) vertically.
    -f, --force Continue even if we get an sql error.
    -g, --no-named-commands
    Named commands are disabled. Use \* form only, or use
    named commands only in the beginning of a line ending
    with a semicolon ( Since version 10.9 the client now
    starts with this option ENABLED by default! Disable with
    '-G'. Long format commands still work from the first
    line. WARNING: option deprecated; use
    --disable-named-commands instead.
    -G, --named-commands
    Enable named commands. Named commands mean this program's
    internal commands; see mysql> help . When enabled, the
    named commands can be used from any line of the query,
    otherwise only from the first line, before an enter.
    Disable with --disable-named-commands. This option is
    disabled by default.
    -i, --ignore-spaces Ignore space after function names.
    --local-infile Enable/disable LOAD DATA LOCAL INFILE.
    -b, --no-beep Turn off beep on error.
    -h, --host=name Connect to host.
    -H, --html Produce HTML output.
    -X, --xml Produce XML output
    --line-numbers Write line numbers for errors.
    -L, --skip-line-numbers
    Don't write line number for errors. WARNING: -L is
    deprecated, use long version of this option instead.
    --no-pager Disable pager and print to stdout. See interactive help
    (\h) also. WARNING: option deprecated; use
    --disable-pager instead.
    --no-tee Disable outfile. See interactive help (\h) also. WARNING:
    option deprecated; use --disable-tee instead
    -n, --unbuffered Flush buffer after each query.
    --column-names Write column names in results.
    -N, --skip-column-names
    Don't write column names in results. WARNING: -N is
    deprecated, use long version of this options instead.
    -O, --set-variable=name
    Change the value of a variable. Please note that this
    option is deprecated; you can set variables directly with
    --variable-name=value.
    -o, --one-database Only update the default database. This is useful for
    skipping updates to other database in the update log.
    --pager[=name] Pager to use to display results. If you don't supply an
    option the default pager is taken from your ENV variable
    PAGER. Valid pagers are less, more, cat [> filename],
    etc. See interactive help (\h) also. This option does not
    work in batch mode.
    -p, --password[=name]
    Password to use when connecting to server. If password is
    not given it's asked from the tty.
    -P, --port=# Port number to use for connection.
    --prompt=name Set the mysql prompt to this value.
    -q, --quick Don't cache result, print it row by row. This may slow
    down the server if the output is suspended. Doesn't use
    history file.
    -r, --raw Write fields without conversion. Used with --batch
    -s, --silent Be more silent.
    -S, --socket=name Socket file to use for connection.
    -t, --table Output in table format.
    -T, --debug-info Print some debug info at exit.
    --tee=name Append everything into outfile. See interactive help (\h)
    also. Does not work in batch mode.
    -u, --user=name User for login if not current user.
    -U, --safe-updates Only allow UPDATE and DELETE that uses keys.
    -U, --i-am-a-dummy Synonym for option --safe-updates, -U.
    -v, --verbose Write more. (-v -v -v gives the table output format)
    -V, --version Output version information and exit.
    -w, --wait Wait and retry if connection is down.
    --connect_timeout=#
    --max_allowed_packet=#
    --net_buffer_length=#
    --select_limit=#
    --max_join_size=#

    Default options are read from the following files in the given order:
    /etc/my.cnf /var/lib/mysql/my.cnf ~/.my.cnf
    The following groups are read: mysql client
    The following options may be given as the first argument:
    --print-defaults Print the program argument list and exit
    --no-defaults Don't read default options from any options file
    --defaults-file=# Only read default options from the given file #
    --defaults-extra-file=# Read this file after the global files are read

    Variables (--variable-name=value)
    and boolean options {FALSE|TRUE} Value (after reading options)
    --------------------------------- -----------------------------
    auto-rehash FALSE
    character-sets-dir (No default value)
    default-character-set (No default value)
    compress FALSE
    database (No default value)
    vertical FALSE
    force FALSE
    named-commands FALSE
    local-infile FALSE
    no-beep FALSE
    host (No default value)
    html FALSE
    xml FALSE
    line-numbers TRUE
    unbuffered FALSE
    column-names TRUE
    port 3306
    prompt mysql>
    quick FALSE
    raw FALSE
    socket /tmp/mysql.sock
    table FALSE
    debug-info FALSE
    user univer1_main
    safe-updates FALSE
    i-am-a-dummy FALSE
    connect_timeout 0
    max_allowed_packet 16777216
    net_buffer_length 16384
    select_limit 1000
    max_join_size 1000000
    bash-2.05a$
    bash-2.05a$

  • #2
    You missed <

    mysql -u univer1_main -p bC7Fhh1h < univer1_forum

    Comment


    • #3
      hmm..still not working...

      mysql -u univer1_main -p bC7Fhh1h < universal-muscle_com_-_vb < /home/univer1/public_html/back/universal-muscle_com_-_vb

      Comment


      • #4
        mysql -u univer1_main -p bC7Fhh1h universal-muscle_com_-_vb < /home/univer1/public_html/back/universal-muscle_com_-_vb.sql

        Comment


        • #5
          I've been at this all day. It's still not working.

          Comment


          • #6
            ok...

            HAve you create a database?

            Have you created a user and password?

            Did you give permissions to the user?

            Are your names correct?

            by default in cPanel databases are created with loginame_

            same with users

            should look like

            mysql -uLOGINAME_username -pPASSWORD LOGINAME_databasename < back/filename.sql

            Comment


            • #7
              may I PM you my info and make sure i'm doing everything correct?

              Comment


              • #8
                leave off the actual password after -p (hope that ain't you real password you posted publicly ? )

                try

                mysql -u univer1_main -p univer1_forum < /home/univer1/public_html/back/universal-muscle_com_-_vb

                when prompted for password enter password for mysql user univer1_main

                how did you backup your forum database in the first place ? can you post the command line you used if you used mysqldump

                Also try this command line and see if you can connect

                mysqladmin -u univer1_main -p version
                :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                :: Nginx SPDY SSL - World Flags Demo [video results]
                :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X