Announcement

Collapse
No announcement yet.

Step 2 (HELP)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Step 2 (HELP)

    Ok, I entered all of the values in the config.php file correctly. On step 2, it says

    d:\hosting\mattmorse425\forums\includes\db_mysql.php on line 140.

    Why d:/hosting?? How can I change this?

  • #2
    It should say more than that. What is the complete message?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in d:\hosting\mattmorse425\forums\includes\db_mysql.php on line 140
      The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.

      Comment


      • #4
        By the way, what I posted above is the complete messege.

        Comment


        • #5
          This error means either:

          1. One or more of the following is wrong in your config.php file:

          $servername (except in rare cases, this should almost always be left as 'localhost' or '127.0.0.1')
          $dbusername
          $dbpassword
          $dbname

          If you are unsure of what the appropriate values are then you will need to ask your web host.

          2. Or that this db user is not assigned to that database or does not have permission to access MySQL to create or access a database. You may need to first manually create the database and assign the db user to it. Since each web host is different, if you do not know how to do this then contact your web host for help.

          3. Or you are running MySQL 4.1.x. As of MySQL 4.1.X there is a new password hashing system. PHP4 does not have builtin support for it as of yet, however PHP5 does. In order for your old PHP4 MySQL clients to be able to connect to the MySQL 4.1.X database you need to set an OLD_PASSWORD. You should be able to run the following Query to make it possible for PHP4 to access the MySQL 4.1.X database.

          SET PASSWORD FOR 'username'@'localhost' = OLD_PASSWORD('password');

          More info is here:
          http://dev.mysql.com/doc/mysql/en/password-hashing.html
          http://dev.mysql.com/doc/mysql/en/up...-from-4-0.html
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Steve, when it says "dbname" does that mean something similar to "/forums" or something similar to "db_XXXXX"?

            Comment


            • #7
              It means the actual name of the database itself.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Example? I am really confused.

                Comment


                • #9
                  Well, I don't know how to find my database name. Do you know how I can find my database name?

                  Comment


                  • #10
                    Contact your host, they should know what it is, if you have that option.

                    Comment


                    • #11
                      I now know my database name, but it still does not work. I belive it is because of the D:hosting at the beggining of the URL. Anyone know why this is there and how to fix the problem?

                      Comment


                      • #12
                        That does not make any diffrence with the database.

                        Make sure you have the correct database name, server name, database username, and username password entered.

                        If you are unaware of what any of these settings are, please contact your host.

                        Comment


                        • #13
                          OK, what exactly should I say?

                          Comment


                          • #14
                            Well, I fixed the problem and VBulletin is working great.

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X