Announcement

Collapse
No announcement yet.

Generally broken layout

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Zachery
    replied
    IIRC this is actually a Firefox bug

    Leave a comment:


  • Zenith
    replied
    Originally posted by Dennis Olson
    "Yes it works in IE. However..."

    There IS no however. The FF browser has differences in how it renders HTML. There are hundreds of threads here that discuss the issue. Read some and you'll see....
    Differences? Yep, IE is non-compliant and renders incorrectly. Firefox is compliant and renders correctly.

    Run your site through validator.w3.org. I had a similar issue with form widths in firefox. From memory it was an unclosed tag or 2 in navbar that I picked up through the validator results.

    vb3 itself validates by the way (run www.vbulletin.com through validator.w3.org), and if you're worried about catering to compliant browsers rather than just microsoft's proprietry "browser" then you should keep your site compliant with XHTML 1.0 transitional by closing image tags, using <br /> instead of <br> etc. Don't just plonk code in coz IE seems to handle it.

    Leave a comment:


  • ChrisLM2001
    replied
    Originally posted by G4cE
    Any ideas on what style vars would result in this?
    Robin, what did you change exactly? Because it's effecting the table width of the form. This can happen if there's a clash between a class and style tags.

    Can you copy just the code that you changed and paste it here?

    Chris

    Leave a comment:


  • Dennis Olson
    replied
    That's because you've altered SOME settings, but not all that you need to. The threads I'm speaking of cover your needs. There are LOTS of them, and it will be FAR faster for you to find what you need by SEARCH.

    Leave a comment:


  • G4cE
    replied
    Dennis, thanks for the reply. I appreciate what your saying and will look into this. My only concern is that when viewing the standard vbulletin community forum it works fine in FF, yet my own does not. I have not edited any templates, other than to make categorys have a space, all I have done is alter style vars to change the colours and it has resulted in the problems i am experiencing.

    Any ideas on what style vars would result in this?

    Your help is greatly appreciated.

    Rob

    Leave a comment:


  • Dennis Olson
    replied
    "Yes it works in IE. However..."

    There IS no however. The FF browser has differences in how it renders HTML. There are hundreds of threads here that discuss the issue. Read some and you'll see....

    EDIT - Yes, there ARE settings in the templates that can affect how FF renders the page. Many of the threads I spoke of contain what you need.

    Leave a comment:


  • G4cE
    replied
    Hmm yes it works in IE, however, this site here is not much nigger than mine, and viewing it in firefox it still auto shrinks the cells to fit the screen, but on my version it doesn't. I still think theirs a problem somewhere

    Leave a comment:


  • Dennis Olson
    replied
    Are you using the Firefox browser? If so, try it with IE.

    Leave a comment:


  • G4cE
    replied
    I hope not, why let you set it at that size if it does not work?

    that is the same width as my website, so i would like the 2 to match

    Leave a comment:


  • jamesyfx
    replied
    I think your main issue is that your main table width is just too small. :P

    Leave a comment:


  • G4cE
    replied
    Can anyone help with these issues please?

    Leave a comment:


  • G4cE
    started a topic Generally broken layout

    Generally broken layout

    I have been attempting to alter colours and styles on my forum, and have somehow broken the layout.

    Their are 2 main issues, both of which i have attached pictures of. Im not really sure what i have done to effect these, the black lines problem i don't know how to fix, the post icon / avatar boxes i tried to alter the form sizes in style manager however it could not fix the problem.

    Your help as ever will be greatly appreciated!

    Regards,

    Robin Smith
    Attached Files
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X