Announcement

Collapse
No announcement yet.

Step 2 Problem...mySQL..

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Step 2 Problem...mySQL..

    Im pretty new to Vbulletin and its installation steps and at Step 2 of installation i get this error...

    Attempting to attach to database


    Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in /home2/technis/public_html/forum/includes/db_mysql.php on line 140
    The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.

    Which values are these? Is it the username and pw...if so where do i get these from because at the moment i have the cpanel u/p values in...


    Thanks
    Spice

  • #2
    This error means either:

    1. One or more of the following is wrong in your config.php file:

    $servername (except in rare cases, this should almost always be left as 'localhost' or '127.0.0.1')
    $dbusername
    $dbpassword
    $dbname

    If you are unsure of what the appropriate values are then you will need to ask your web host.

    2. Or that this db user is not assigned to that database or does not have permission to access MySQL to create or access a database. You may need to first manually create the database and assign the db user to it. Since each web host is different, if you do not know how to do this then contact your web host for help.

    3. Or you are running MySQL 4.1.x. As of MySQL 4.1.X there is a new password hashing system. PHP4 does not have builtin support for it as of yet, however PHP5 does. In order for your old PHP4 MySQL clients to be able to connect to the MySQL 4.1.X database you need to set an OLD_PASSWORD. You should be able to run the following Query to make it possible for PHP4 to access the MySQL 4.1.X database.

    SET PASSWORD FOR 'username'@'localhost' = OLD_PASSWORD('password');

    More info is here:
    http://dev.mysql.com/doc/mysql/en/password-hashing.html
    http://dev.mysql.com/doc/mysql/en/up...-from-4-0.html
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I am having this exact same problem. I am sure that I made all of the modifications to config.php correctly. I am sure that the values I entered into config.php match what I have set up in my website's control panel. But for some reason, when I try to run the installation script, I get this exact same error.

      STEVE SAID IN THE PREVIOUS POST:

      3. Or you are running MySQL 4.1.x. As of MySQL 4.1.X there is a new password hashing system. PHP4 does not have builtin support for it as of yet, however PHP5 does. In order for your old PHP4 MySQL clients to be able to connect to the MySQL 4.1.X database you need to set an OLD_PASSWORD. You should be able to run the following Query to make it possible for PHP4 to access the MySQL 4.1.X database.

      Don't get mad at me Steve, but can you dumb it down a little for me. I'm not sure exactly what you are saying here... only because I am just not that fluent with computer lingo... What should my next recourse be if this is the problem?

      1. contact my webhost and ask that they upgrade to php5?
      2. run a query to make the password hashing work in the old fashion?
      3. ???

      DAZED AND CONFUSED

      Comment


      • #4
        First, find out which version of MySQL is running on your server. No sense fretting over this until you get that bit of information.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X