Announcement

Collapse
No announcement yet.

Search IPs slows server to crawl

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Search IPs slows server to crawl

    Hi Everyone,

    I run the forums over at http://forums.comicbookresources.com/ ... it's a very active forum running on a SCSI based AMD 2400+ dual processor system. In addition to hosting the forums, it also hosts the ad server for Comic Book Resources. So there's a lot of PHP/MySQL going on with this box, but it's pretty fast and shouldn't have any problems handling the load.

    For the past four or five weeks now I've noticed that the load average on the system seems to randomly go sky high and memory usage (1 gig on board) starts getting eaten up quickly, while it's usually using only about 1/2 gig. When the load average is high, the CPUs are also mostly idle. It's a strange occurence that I've not been able to get to the bottom of.

    On thing I have noticed is that when moderators search for IP address of users in the ModCP and set the depth to search to "2," it makes the forums completely unresponsive. You can't bring up the front page or any page until it seems to have completed its search. Has anyone else had this happen? Is there a fix?

    I'd like to solve this problem first to see if it's what is causing all the problems with the forums before bringing in a tech to look at things. Any thoughts folks?
    -- Jonah Weiland
    http://www.boilingpoint.com/

  • #2
    It's a known issue for very large sites...
    vBulletin v3.8.0's Implementation of Google Adsense Should Be Avoided At All Costs - Do Your Own Adsense Implementation

    Comment


    • #3
      Yup. The fix is to index the IPaddress in the POSTS table. BTW, for a busy/large forum, you need at least 2 GB RAM. Ask me how I know these things....

      Comment


      • #4
        Originally posted by Dennis Olson View Post
        Yup. The fix is to index the IPaddress in the POSTS table. BTW, for a busy/large forum, you need at least 2 GB RAM. Ask me how I know these things....
        Makes you wonder why its not done by default... I've spent ages trying to work out how our mods kept killing our forum (~6mill posts) - turns out this is the problem, we have repeated re-registering users who are banned - so use the ip search frequently.

        Gonna add it when it calms down tonight, we're still over 400 users at the moment.

        Edit: I performed the index late lastnight, worked wonders - the server hasn't mysteriously died yet today
        Last edited by TimIgoe; Thu 18 Oct '07, 5:19am.

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X